XF 2.1 VBSEO Re-directs

JamesAus

Active member
Regarding re-directs for VBSEO, I found the following site - https://www.rivmedia.co.uk/vbseo-xenforo-rewrite-rules-redirect-vbseo-urls-xenforo/1828. It looks like what I need to use is the following:

RewriteEngine on
RewriteRule [^/]+/([\d]+)-.+-([\d]+).html showthread.php?t=$1&page=$2 [NC,L]
RewriteRule [^/]+/([\d]+)-.+.html showthread.php?t=$1 [NC,L]
What I noticed in that URL was the following also:
These htaccess rules will not work unless you have the 301 Redirect script provided for your vbulletin version, this can be found in the modifications section at xenforo.com
I haven't managed to find that, however. Does anyone have a link to it?
 

JamesAus

Active member
Thanks for that. I've set it up and trying to get the redirects working on my test forum which is www.mysite.org/forum/ compared to www.mysite.net/forum which is my live site. It's not working however and I'm getting the following:

Oops! We ran into some problems.​

The requested page could not be found.

Is there a way to verify the re-directs on a test site? I'm quite worried and don't want to go-live and then suddenly have broken links everywhere due to this.
 

bzcomputers

Well-known member
Shared hosting / VPS /or Dedicated server? Did you do the install yourself?

Have you modified the htaccess file? Are rewrites enabled for that domain so the htaccess will work?
 

JamesAus

Active member
Shared hosting / VPS /or Dedicated server? Did you do the install yourself?

Have you modified the htaccess file? Are rewrites enabled for that domain so the htaccess will work?

It's a dedicated server. I did the install of XenForo myself yes, and seems to be working fine but not for the .htaccess file.

How do I see if rewrites are enabled? My .htaccess is like this:

# Mod_security can interfere with uploading of content such as attachments. If you
# cannot attach files, remove the "#" from the lines below.
#<IfModule mod_security.c>
# SecFilterEngine Off
# SecFilterScanPOST Off
#</IfModule>

ErrorDocument 401 default
ErrorDocument 403 default
ErrorDocument 404 default
ErrorDocument 405 default
ErrorDocument 406 default
ErrorDocument 500 default
ErrorDocument 501 default
ErrorDocument 503 default

<IfModule mod_rewrite.c>
RewriteEngine On

# If you are having problems with the rewrite rules, remove the "#" from the
# line that begins "RewriteBase" below. You will also have to change the path
# of the rewrite to reflect the path to your XenForo installation.
#RewriteBase /xenforo

# This line may be needed to workaround HTTP Basic auth issues when using PHP as a CGI.
#RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -l [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^.*$ - [NC,L]
RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
RewriteRule ^.*$ index.php [NC,L]
</IfModule>


RewriteEngine on
RewriteRule [^/]+/([\d]+)-.+-([\d]+).html showthread.php?t=$1&page=$2 [NC,L]
RewriteRule [^/]+/([\d]+)-.+.html showthread.php?t=$1 [NC,L]
 

bzcomputers

Well-known member
That htaccess is a little incorrect, but I don't think that is your issue. But you should make the changes below to it.

Are you sure mod_rewrite is installed and enabled?

# Mod_security can interfere with uploading of content such as attachments. If you
# cannot attach files, remove the "#" from the lines below.
#<IfModule mod_security.c>
# SecFilterEngine Off
# SecFilterScanPOST Off
#</IfModule>

ErrorDocument 401 default
ErrorDocument 403 default
ErrorDocument 404 default
ErrorDocument 405 default
ErrorDocument 406 default
ErrorDocument 500 default
ErrorDocument 501 default
ErrorDocument 503 default

<IfModule mod_rewrite.c>
RewriteEngine On

RewriteRule [^/]+/([\d]+)-.+-([\d]+).html showthread.php?t=$1&page=$2 [NC,L]
RewriteRule [^/]+/([\d]+)-.+.html showthread.php?t=$1 [NC,L]

# If you are having problems with the rewrite rules, remove the "#" from the
# line that begins "RewriteBase" below. You will also have to change the path
# of the rewrite to reflect the path to your XenForo installation.
#RewriteBase /xenforo

# This line may be needed to workaround HTTP Basic auth issues when using PHP as a CGI.
#RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -l [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^.*$ - [NC,L]
RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
RewriteRule ^.*$ index.php [NC,L]
</IfModule>
 

bzcomputers

Well-known member
If you were/are running vbulletin on the same server then you know at least mod_rewrite is installed. Then you would just have to verify if it is enabled for the entire server or currently just the domain or directory vbulletin is on - you would need to check virtual host configuration for this.
 

JamesAus

Active member
If you were/are running vbulletin on the same server then you know at least mod_rewrite is installed. Then you would just have to verify if it is enabled for the entire server or currently just the domain or directory vbulletin is on - you would need to check virtual host configuration for this.

Sure, I must have re-write enabled on my main domain then. Perhaps I don't on my test domain, I'm not sure. I've asked my host to check for me.
 

JamesAus

Active member
My hosts have changed the .htacess and said it is enabled, but I still get the same error :(

# Mod_security can interfere with uploading of content such as attachments. If you
# cannot attach files, remove the "#" from the lines below.
#<IfModule mod_security.c>
# SecFilterEngine Off
# SecFilterScanPOST Off
#</IfModule>

RewriteEngine On

<IfModule mime_module>
AddHandler application/x-httpd-ea-php56 .php .php5 .phtml
</IfModule>

ErrorDocument 401 default
ErrorDocument 403 default
ErrorDocument 404 default
ErrorDocument 405 default
ErrorDocument 406 default
ErrorDocument 500 default
ErrorDocument 501 default
ErrorDocument 503 default

<IfModule mod_rewrite.c>

RewriteRule [^/]+/([\d]+)-.+-([\d]+).html showthread.php?t=$1&page=$2 [NC,L]
RewriteRule [^/]+/([\d]+)-.+.html showthread.php?t=$1 [NC,L]

# If you are having problems with the rewrite rules, remove the "#" from the
# line that begins "RewriteBase" below. You will also have to change the path
# of the rewrite to reflect the path to your XenForo installation.
#RewriteBase /xenforo

# This line may be needed to workaround HTTP Basic auth issues when using PHP as a CGI.
#RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -l [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^.*$ - [NC,L]
RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
RewriteRule ^.*$ index.php [NC,L]
</IfModule>
 
Top