• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.5 vb4 -> xf, install goes fine, import overwrites userid 1, existing admin does not have permissions

#1
Ok, so we are attempting to import our existing vb4 site into a test xf forum. Due to the size of the site (1.5 mil threads, 15 mil posts, 300k+ users) we're using the Big Board importer, which has not been a smooth and painless experience.

The problem we're running into right now is that posts & threads have imported, and users however, when logging in, my admin account does not have permission to do anything. Going into the db, we've switched the admin account (which has an ID of 10xxxx) is_admin and is_moderator settings to 1; this results in allowing my admin account to log into the admin control panel, however the only things that show up there are the "tools" tab with the Diagnostics menu. None of the other admin tools are visible. For some reason only 48 users show up in the admin control panel user count as well

When doing a clean install, the default admin works just fine. Unfortunately the default admin appears to be overwritten and deleted when using the Big Board import?
 

Jake Bunce

XenForo moderator
Staff member
#2
Yeah... the big board importer requires extra effort.

user_id 1 will get overwritten by user_id 1 from the source forum.

For your 10xxx admin account you probably want to specify super admin privileges in the library/config.php file. The default super admin is user_id 1. Once you specify your user_id then you should have full admin access. is_admin is also required.

Permissions on the front end can also sometimes be an issue after a big board importer. Make sure your group permissions are setup the way you want. If you can't see anything on the front end then rebuild your user info:

Admin CP -> Tools -> Rebuild Caches

If that still doesn't work then you might need to rebuild the forum info as well.
 
#6
Thank you, it's installed and rebuilding caches as I type. I've changed permissions so that the forums are viewable when someone is not logged in, but it would appear that when I log in with my admin account.

AND crap: <!-- Mysqli statement execute error : The number of columns in the result set differs from the numb er of bound buffers. You must reset the statement, rebind the result set columns, and execute the s

This occurred during the rebuild of conversations.
 
#7
Exact error message:

Error Info
Zend_Db_Statement_Mysqli_Exception: Mysqli statement execute error : The number of columns in the result set differs from the number of bound buffers. You must reset the statement, rebind the result set columns, and execute the statement again - library/Zend/Db/Statement/Mysqli.php:214
Generated By: Unknown Account, Today at 12:28 PM
Stack Trace
#0 /var/www/xenforo_bladeforums/library/Zend/Db/Statement.php(297): Zend_Db_Statement_Mysqli->_execute(Array)
#1 /var/www/xenforo_bladeforums/library/Zend/Db/Adapter/Abstract.php(479): Zend_Db_Statement->execute(Array)
#2 /var/www/xenforo_bladeforums/library/XenForo/Model.php(219): Zend_Db_Adapter_Abstract->query('?????SELECT con...', 1682874, 2)
#3 /var/www/xenforo_bladeforums/library/XenForo/Model/Conversation.php(127): XenForo_Model->fetchAllKeyed('?????SELECT con...', 'user_id', 1682874, 'deleted')
#4 /var/www/xenforo_bladeforums/library/XenForo/DataWriter/ConversationMaster.php(434): XenForo_Model_Conversation->getConversationRecipients(1682874)
#5 /var/www/xenforo_bladeforums/library/XenForo/Deferred/Conversation.php(28): XenForo_DataWriter_ConversationMaster->rebuildRecipients()
#6 /var/www/xenforo_bladeforums/library/init_rebuilder.php(55): XenForo_Deferred_Conversation->execute(Array, Array, 8, 'Rebuilding... C...')
#7 /var/www/xenforo_bladeforums/library/Conversation.php(16): cliRunDeferredTask(Array)
#8 /var/www/xenforo_bladeforums/library/CLIRebuilds.php(25): include('/var/www/xenfor...')
#9 {main}
Request State
array(3) {
["url"] => string(7) "http://"
["_GET"] => array(0) {
}
["_POST"] => array(0) {
}