Resource icon

vB4 Importer 3.6b2

No permission to download

Adam Howard

Well-known member
Question:

Does this importer sill work on vBulletin to XenForo?

Answer:

Yes, this importer works on all current version of vBulletin and XenForo.


Questions:


Will this importer work with XenForo 1.2?

Answer:

There is no way of knowing that until it is released. However, I suspect the answer is yes, and if not an update will be released (provider there isn't a default one provided by XenForo).

Questions:

Is there a vBulletin 5 importer?

Answer:

Not at this time. It is unclear if a default importer made by XenForo will be released for this. One maybe made sometime after XenForo 1.2, but it will be done much later.
 

Triops

Well-known member
Maybe I am overreading the important point, I beg for help, please.

How do I import the "thanks" from this vB plugin for vB 3.7x to the "likes" of xenForo?
http://www.vbulletin.org/forum/showthread.php?t=122944 (vB 3.6 / 3.7)
http://www.vbulletin.org/forum/showthread.php?t=165673 (vB 3.8)
http://www.vbulletin.org/forum/showthread.php?t=231666 (vB 4.x)

I did not get the solution here:
http://xenforo.com/community/threads/vb4-importer.36391/page-8#post-531458

When testing the import scripts for vB 3.7 (worked very smooth) there was no such option.

Many thanks in advance,
regards
PyroM
 

Triops

Well-known member
Question:

Does this importer sill work on vBulletin to XenForo?

Answer:

Yes, this importer works on all current version of vBulletin and XenForo.
Ok, I've read the whole thread again and just ask to make it sure:
this importer does NOT work on vB 3.7x?!
I've imported my vB 3.7x (local test installation) with the normal built in importer, but that one does not care about vB albums and the "post thank you likes" (see above) and probably not for thread prefixes and custom user fields (I don't remember correctly).

So, conclusion:
this vB4.x importer does more than the built in 3.x importer. Since this one supports vB 4.x only it is wise to upgrade vB 3.7x to 4.x (what version would be best?!) and then use this importer to get everything imported?!
I own a vB 4 CMS Suite license but never used it on my live system. I can use it for upgrading before transfering to xenForo.

Am I on the right way?!

Any hint is appreciated, thanks a lot!
 

Adam Howard

Well-known member
Ok, I've read the whole thread again and just ask to make it sure:
this importer does NOT work on vB 3.7x?!
I've imported my vB 3.7x (local test installation) with the normal built in importer, but that one does not care about vB albums and the "post thank you likes" (see above) and probably not for thread prefixes and custom user fields (I don't remember correctly).

So, conclusion:
this vB4.x importer does more than the built in 3.x importer. Since this one supports vB 4.x only it is wise to upgrade vB 3.7x to 4.x (what version would be best?!) and then use this importer to get everything imported?!
I own a vB 4 CMS Suite license but never used it on my live system. I can use it for upgrading before transfering to xenForo.

Am I on the right way?!

Any hint is appreciated, thanks a lot!
This importer is made for vBulletin 4 moving to XenForo :)

It does not support vBulletin 3. XenForo already has an importer that works for that (made by XenForo. ;)

Yes, you can update your vBulletin before importing to XenForo.

No, updating will not help you port over 3rd party add-ons.
 

Triops

Well-known member
Thanks Adam, so I interpret your answer this way:
  • this importer does more than the built in vB 3 importer - it imports additionally user albums, thread prefixes and custom user fields. Upgrading to vB4 makes sense to import those things. To which version? 4.0, 4.1, 4.2?
  • I understand that it does not import 3rd party addons - but then I don't understand that message:
    http://xenforo.com/community/threads/vb4-importer.36391/page-8#post-531458
theRKF said:
We're using Abe1's Post Thank You Hack on vB. I've read a bit about importing Thanks as Likes from links earlier in this thread, but they seem a bit dated, and I don't think they address this particular issue. Any suggestions would be greatly appreciated!
Jake Bunce said:
You need to install the addon-vb4ToXf11.xml file through your Admin CP as an addon. That, in addition to the files you uploaded for this importer, will enable the "post thanks" module.
Will it work or not? Of course I will try but since the import takes 3++ hours it would be easier to know ;)

THANKS AGAIN!
 

Triops

Well-known member
Ok, I see - addon-vb4ToXf11.xml is the secret... PyroM, read more carefully the foreign language!
Now I have to find that file ;)
 

Triops

Well-known member
Thanks a lot for you offer!
I will prepare the final, the live import very carefully. There are lots of things to check, understand, organize, find addons, let addons be coded and more before. In the end I highly appreciate your offered help, but before I have to understand more.
And I've found the addon-vb4ToXf11.xml - its included within the resource. I will give it a try for another test import.
 

Adam Howard

Well-known member
Thanks a lot for you offer!
I will prepare the final, the live import very carefully. There are lots of things to check, understand, organize, find addons, let addons be coded and more before. In the end I highly appreciate your offered help, but before I have to understand more.
And I've found the addon-vb4ToXf11.xml - its included within the resource. I will give it a try for another test import.
Keep in mind that this importer is only for vBulletin 4. There is a vBulletin 3 importer, but its comes with XenForo (as they make and support it).
 

Adam Howard

Well-known member
Question:

Does this work with vBulletin and XenForo 1.2 ?

Answer:

As far as I can tell, yes. Was able to import someone community using XenForo 1.2 Beta 1

However, keep in mind this is still BETA software and things can change.
 

Triops

Well-known member
I can confirm this. Imported today full vB4.2 installation (updated for test purposes from vB3.7) with 500k posts and 155k "thank you" (=likes) and 2GB of attachments with current importer version 3.6b2 to xf 1.2 b1.
For the archive: the 3rd party vB4 importer imports some more, than the official vB3 importer, for example "thank you hack" at least starting from version 5.4 - what is quite ooooold. No need to update the vB "thank you" addon to a version 7.x or more.
So, it is probably wise to prefer this addon over the vB3.x importer, even when one still have a vB3.x installation (and a vB4.x licence).
 
When importing from vbulletin 4.2.1 to XenForo 1.1.5 with vB4 Importer 3.6b2 I get an error:

“Manually Merge Users
The following users conflicted with existing users' names or email addresses. Please resolve these conflicts”

There are many user name conflicts, but the conflicting user names in reality are not the same. The importer thinks “Mörkö” and “Morko” are the same and want to merge them. The same with “harka” and “härkä”.

How can I solve this problem?
 

Adam Howard

Well-known member
When importing from vbulletin 4.2.1 to XenForo 1.1.5 with vB4 Importer 3.6b2 I get an error:

“Manually Merge Users
The following users conflicted with existing users' names or email addresses. Please resolve these conflicts”

There are many user name conflicts, but the conflicting user names in reality are not the same. The importer thinks “Mörkö” and “Morko” are the same and want to merge them. The same with “harka” and “härkä”.

How can I solve this problem?
You merge them.

o = ö

It's still the letter O, just with localized symbols. And while it maybe pronounced differently, its still the letter O

The importer and as far as I know, XenForo, does not know how to distinguish the difference.
 

Adam Howard

Well-known member
No point in that, they are different users. I should change one of the the user names, but I do not want to do that.

If this is true, I am not sure if I want to convert to XenForo at all.
I know when I merged the code into this importer.... I didn't add support for it (have no plans to either).

You maybe stuck where you are.... I just tried to do a test run importing IPB, vBulletin 5, phpBB, SMF, and MyBB

All of them gave me errors when trying to use the user name “Mörkö” and “Morko”. I'm very surprised vBulletin 4 allows it though.

@Jake Bunce maybe able to convert you manually.
 

Jake Bunce

XenForo moderator
Staff member
@drifter4ever

I spoke with Mike. This is a behavior of MySQL (it is case and accent insensitive). There is no quick workaround. You are advised to deal with the conflicts and inform the users. Or perhaps deal with those conflicts in vB before importing so the changes are ready to go.

Note that your users can login with their email address if they don't know their username after the import. That way they can still login while you deal with change requests.
 

rolypoly

Member
i am trying to import from vb 4.2.0 to xf1.1.5

i am using vBulletin4-Importer-3.6b2
1. i went to upload files found in 'upload' directory to the root directory (replacing library and everything found inside)
2. when i go back to admin panel, it return a blank page..

any ideas what i am missing?
 
Last edited:

Adam Howard

Well-known member
i am trying to import from vb 4.2.0 to xf1.1.5

i am using vBulletin4-Importer-3.6b2
1. i went to upload the folders..
2. when i go back to admin panel, it return a blank page..

any ideas what i am missing?
Have you installed the add-on or did you just suddenly end up with a blank page?

Have you tried adding this into your config.php file?

PHP:
$config['enableListeners'] = false;
You're the first person whoever said they got a white page.

If adding that into your config.php file does not solve it.... Your host is likely the issue (or you have a bad add-on from someone else as the importer doesn't touch anything outside of xenforo).
 

rolypoly

Member
i am seeing this error:
Code:
[Tue Jul 02 08:48:49 2013] [error] [client 66.249.73.121] PHP Fatal error:  require(): Failed opening required '/home/_/public_html/library/XenForo/Autoloader.php' (include_path='.:/usr/share/pear:/usr/share/php') in /home/_/public_html/index.php on line 6
 

Adam Howard

Well-known member
i am seeing this error:
Code:
[Tue Jul 02 08:48:49 2013] [error] [client 66.249.73.121] PHP Fatal error:  require(): Failed opening required '/home/_/public_html/library/XenForo/Autoloader.php' (include_path='.:/usr/share/pear:/usr/share/php') in /home/_/public_html/index.php on line 6
This looks like a host issue as that error seems to not even like index.php

include_path='.:/usr/share/pear:/usr/share/php
 
Top