XF 2.2 utf8mb4 - not all tables changed?

Andre Daub

Active member
Hi, after upgrading to 2.2.2 i have run the command to change the db to utf8mb4.

Now emojis work, and everything is perfect. 👌

But i have one question, when i look into my db, i see that there are many tables still on utf8_general_ci.

Is this right, and no problem?
 

Attachments

  • db-utf8.png
    db-utf8.png
    259.9 KB · Views: 24

AndyB

Well-known member
Please run the following command again, it will update those tables which were skipped the first time you ran the command.

php cmd.php xf:convert-utf8mb4
 

Andre Daub

Active member
I ran this command multiple times and it says all 84 tables were changed. But in mysql it looks like in the screenshot i postet above.

Everythings runs nice and there seems to be no mistake.
 

twollert

Active member
I have the same problem. After I ran the command about half of the tables are "utf8mb4_general_ci", the other half are "utf8_general_ci" when I check them in phpMyAdmin. The MySQL dump still shows
Code:
/*!40101 SET character_set_client = utf8 */;
several times.

What can I do to get valid dumps?
 
Top