• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.4 Using REST Rss feeds?

MattH

Active member
#1
I built a Rest rss feed via the ebay affiliate program to populate a forum, it worked when I hit 'Import Now' several times, but has since stopped pulling in any data (within a day) either cronned or manually used. Does anyone know why the Rest rss might suddenly stop, is it something on XF side or an issue with the feed itself?

Not sure exactly how to troubleshoot it.
 

Mike

XenForo developer
Staff member
#2
I would guess it's an issue with the feed related to its unique identifier. We use the feed URL or another unique identifier if present in the feed to prevent us from double posting entries. If this isn't done correctly in the feed, we don't know whether something has been seen or not.
 

MattH

Active member
#3
I would guess it's an issue with the feed related to its unique identifier. We use the feed URL or another unique identifier if present in the feed to prevent us from double posting entries. If this isn't done correctly in the feed, we don't know whether something has been seen or not.
Yeah, that sounds like the same issue I had with Amazon RSS in the past. Is there any work around? Can I edit the RSS link or something? Here's what the eBay one looks like:

Code:
http://rest.ebay.com/epn/v1/find/item.rss?keyword=%28gift+card%2Cfor%29+-%28voucher%2Cwine%2Cfresh%29&categoryId1=176950&categoryId2=172036&categoryId3=172009&sortOrder=BestMatch&programid=1&campaignid=5337587564&toolid=10039&listingType1=All&lgeo=1&feedType=rss
 

Mike

XenForo developer
Staff member
#4
I see the same entries being repeated a number of times in that (all with the same guid each time), so once each is posted it won't be reposted. It's unlikely that you can change that within the RSS feed.