1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 Users cannot edit their own posts

Discussion in 'Troubleshooting and Problems' started by AliS, Jul 4, 2016.

  1. AliS

    AliS Member

    Hello All,

    I am facing a small issue. Users cannot edit their own posts, although I have set the permissions to "Allow".

    Analyze permissions results:

    Forum Permissions

    Edit post by self: Yes
    Time limit on editing/deleting own posts (minutes): Unlimited

    Where is the problem?
     
  2. AndyB

    AndyB Well-Known Member

    Use the Analyze Permissions to see where the restriction is.
     
  3. Amaury

    Amaury Well-Known Member

    He did that, but having the whole result would be helpful.

    @AliS, would you provide an Analyze Permissions result screenshot for everything? There may be something in another permission causing problems.
     
  4. AliS

    AliS Member

    Global permissions:
    Node permissions:

     
  5. AndyB

    AndyB Well-Known Member

    We need to see the (Details) for these two.

    Edit post by self:
    Yes (Details)

    Time limit on editing/deleting own posts (minutes):
    Unlimited (Details)
     
  6. AliS

    AliS Member

    Forum Permissions - Edit post by self
    Global Permission Values
    Registered: Allow
    Final Value (Global): Yes

    Forum Permissions - Time limit on editing/deleting own posts (minutes)
    Global Permission Values
    Registered: Unlimited
    Final Value (Global): Unlimited
     
  7. Mike

    Mike XenForo Developer Staff Member

    Go to <url>/install/ and rebuild the master data. Does that resolve the issue? If so, then an add-on has broken permission calculation updates at some point. If it doesn't resolve it, then it's possible there could be another add-on at play. I would recommend confirming with all add-ons disabled and on the default style.
     
    Amaury likes this.
  8. AliS

    AliS Member

    Unfortunately, did not work.
    Really a strange issue. I have disabled all add-ons but still the same problem.
    Moderators and administrators can edit the post post, while normal users cannot.

    I think I will need to manage the problem myself.
    Thank you.
     
  9. misteraven

    misteraven Member

    I'm seeing the same issue. Thought it might be an issue with my theme, but I selectedf the XF default theme and am not seeing an option to delete my own posts when testing with a regular member account. Settings are as follows:

    Delete post by self:
    Yes (Details)
    Forum Permissions - Delete post by self
    Global Permission Values
    Member / Subscriber: Allow
    User Value: Allow
    Final Value (Global): Yes
    Time limit on editing/deleting own posts (minutes):
    Unlimited (Details)
    Forum Permissions - Time limit on editing/deleting own posts (minutes)
    Global Permission Values
    Member / Subscriber: Unlimited
    Final Value (Global): Unlimited

    Any help would be appreciated.

    Thanks!
     
  10. Mike

    Mike XenForo Developer Staff Member

    There are a couple other things that come into play with post deletion:
    • If it's the first post in the thread, it would delete the whole thread so it requires that permission.
    • If the thread is closed, the post won't be deletable.
    • If the forum is closed for posting, the post won't be deletable.
    Otherwise, it uses the "standard" permissions you listed.

    If that doesn't cover it, try disabling add-ons. If it still doesn't work, go to <url>/install/ and trigger a master data rebuild. Has that solved it?
     
  11. misteraven

    misteraven Member

    Hey Mike,

    Understand the three points you called out, but this is an open thread and not the thread starting post so it doesn't apply. I'll try the addon suggestion, followed by the rebuild if it doesn't work.

    Thank you for the suggestion. I'll reply here either way for future reference.
     

Share This Page