1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Usergroup CSS colour not prioritizing.

Discussion in 'Troubleshooting and Problems' started by Ross Hardy, Feb 19, 2016.

  1. Ross Hardy

    Ross Hardy Member

    Hi all,

    So I have a new usergroup for donators, naturally, gold coloured. My default usergroup colour is green.
    [​IMG]

    [​IMG]

    You can see the priorities are fine, donor goes above registered, the colours are fine as they do work to a degree.

    However when the secondary usergroup (to registered) is assigned, the user gets the donor banner, but stays green.

    [​IMG]

    I'm wondering what I've done wrong? Any help is appreciated.

    Thanks in advance,
    Ross
     
  2. Tracy Perry

    Tracy Perry Well-Known Member

    Have you tried disabling that add-on that adds additional fields (the support department, etc) and see if it works?
     
  3. Ross Hardy

    Ross Hardy Member

    I did one better and did the enable/disable listeners on the config file to see if it was a plugin at all, and it had no effect.
     
  4. Tracy Perry

    Tracy Perry Well-Known Member

    No, that is NOT one better... because it does not disable any template modifications... you need to go into the add-ons list and disable the check box there (or at least that's been my understanding of it).
     
  5. Ross Hardy

    Ross Hardy Member

    Disabled the support ticket addon, no change unfortunately
     
  6. Tracy Perry

    Tracy Perry Well-Known Member

    Unless things have changed, the rich usernames did not change color from default everywhere. I think @Liam W had an add-on out that forced it most places..

    Does it work correctly in the postbit but not in the member cards?
     
  7. Ross Hardy

    Ross Hardy Member

    Only on manually edited users
     
  8. Tracy Perry

    Tracy Perry Well-Known Member

    What do you mean "only on manually edited users"?
    Do you mean only on users that have the "Donators" added to the secondary manually?
    If so, is the issue the promotions not running and adding the Donator group automatically to the secondary?
     
  9. Ross Hardy

    Ross Hardy Member

    We implemented a task on the website which promotes users secondary usergroups to donator if they are registered as such in an external database (not found in the forum one, literally external). The website will add donator to their secondary usergroups if they are in the database.

    It does that, it gives then the golden donor banner. It however does not change their username colour.

    So we ran some tests, and found that by manually editing user X to donator, it changed the name. But if we let the system automatically do it, the name doesn't change colour but clearly they have been assigned the usergroup.
     
  10. Brogan

    Brogan XenForo Moderator Staff Member

    How is that process being handled?

    Is it via a custom add-on/function or using the built in user group promotion feature?
     
  11. Ross Hardy

    Ross Hardy Member

    Turns out it was the cronjob. Which has now been fixed by the coder :)

    Thanks for all your help!
     

Share This Page