1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

user upgrades question.

Discussion in 'XenForo Questions and Support' started by jonsidneyb, Mar 20, 2012.

  1. jonsidneyb

    jonsidneyb Well-Known Member

    My paypal account has two email addresses. One is related to the forum while the other is related to my store but payments to either address show up in the same account.

    The store is the first email address, I added the account for the forum at a later date.

    I see in the admin control panel that it asks for this. PayPal Primary Account Email.

    What will happen if I use the email address related to the forum instead of the store?
  2. Floris

    Floris Guest

    PayPal connection will probably fail, as it's not matching the primary as expected by PayPal.
  3. jonsidneyb

    jonsidneyb Well-Known Member

    Hmmm, I am using the forums address on vB4 at this time and it is working. I guess I can test it.
  4. Floris

    Floris Guest

    I remember during Alpha testing that I used mrfloris@ for my primary in xenforo, but it was MrFloris@ on PayPal, that went wrong. And reported it. This has been changed since and it's no longer case sensitive. Perhaps secondary addresses might work, but without a guarantee? I don't know. I think this is a requirement or recommendation from PP's side of things. Who, also constantly changes their code.
  5. jonsidneyb

    jonsidneyb Well-Known Member

    It worked.
  6. jonsidneyb

    jonsidneyb Well-Known Member

    I spoke too soon. The paypal transaction worked, it didn't add the person to the usergroup though.
  7. SchmitzIT

    SchmitzIT Well-Known Member

    I can confirm the issue. Same here, using a paypal address with multiple accounts in it. I tried switching the accounts around, but while I get the money, I for some reason do not see the users added automatically.
    Andy Larkins likes this.
  8. jonsidneyb

    jonsidneyb Well-Known Member

    It seems to be working now.
  9. Andy Larkins

    Andy Larkins Member

    I have two upgrades. One works perfect. The other doesnt.

Share This Page