1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

User registration error

Discussion in 'Troubleshooting and Problems' started by Robyn Unc Privette, Jan 4, 2013.

  1. Robyn Unc Privette

    Robyn Unc Privette Active Member

    When users try registering, they are getting this error.

     
  2. Chris D

    Chris D XenForo Developer Staff Member

    That to me looks like it could be an add on that has overwritten the register action.

    Disable all add-ons, and try again.

    Then, re-enable each add-on to work out which is causing the issue.
     
  3. Robyn Unc Privette

    Robyn Unc Privette Active Member

    Mmhmmm, It was the follow user on registration. Shame, but I disabled it and now works.
     
  4. Chris D

    Chris D XenForo Developer Staff Member

    Wait... is that one of mine?!

    That's not been reported before :confused:
     
  5. Robyn Unc Privette

    Robyn Unc Privette Active Member

    LOL!!!!! Follow User On Registration? Fix iT!!! I love that add on!
     
  6. Chris D

    Chris D XenForo Developer Staff Member

  7. Robyn Unc Privette

    Robyn Unc Privette Active Member

    Yes it is :) Very useful!
     
  8. Chris D

    Chris D XenForo Developer Staff Member

    Not if it's breaking things :mad:

    Do you mind listing your other add-ons. I believe this would have been discovered by now if it was a problem for everyone who had downloaded it.

    I suspect it might be a conflict between two add-ons.
     
  9. Robyn Unc Privette

    Robyn Unc Privette Active Member

    1. Add Username Style to Last Post 1.0.1

    2. Add-on Installer 0.2

    3. Addon Block 1.0

    4. Are You A Human? 3.0

    5. Auto Follow on Registration 1.0

    6. Clickable Rows 2.0.0

    7. Cliptheapex.com's Countdown Timer 1.0.1

    8. Conversation Manager 1.0.1

    9. Custom BBCode Manager 1.3.3

    10. Donation Manager 1.0 RC2

    11. Double Post 1.0.5

    12. First Post Moderated 1.0.1

    13. FreddysHouse Tools: Signature Once 1.2.0

    14. GoodForNothing User Alert Enhancement 1.0.0

    15. GoodForNothing XenSocialize 2.0.0

    16. IwDRP Total Forum Thread Views 1.0

    17. Login As User by Waindigo 1.0.2

    18. MassAlert 1.1.0

    19. Member Map 1.0.5

    20. Mobile Icons 1.0

    21. Most Online User 1.2

    22. No Increase In Post Count for Short Posts 1.0a

    23. Nodes As Tabs 1.1.3

    24. Notifications - powered by Gritter 1.5

    25. Post Ratings 1.4.1

    26. Prefix Forum Listing 1.1.0

    27. RCBD - RecentStatus 4.0.2

    28. Responsive Design 1.0

    29. Separate Sticky and Normal Threads 1.0

    30. Showcase 1.0.0 RC3

    31. Signature Restriction 1.2.1

    32. Social Beta 2

    33. sonnb - Bulk importer for smilies management 1.0.4

    34. Start Conversation from Post Bit 1.2

    35. TaigaChat Pro 1.0.4

    36. Template Modification System 1.2

    37. Thread Watchers 1.2

    38. Top Posters Sidebar 1.0

    39. User titles based on posts instead of trophy points 1.0.0

    40. WebGuruBB.com DPC Addon 1.0.2

    41. Xen-TR.com Who Has Visited 2.5.1

    42. Xenique Framework 1.0.0

    43. XenMoods 1.1.3

    44. Xenplaza - Number Viewing a Forum 1.0.0

    45. xenStyles Twitter Module 1.0.1

    46. XFA - BBCode for tabs 1.0.3

    47. [8wayRun.Com] XenHabla (IRC) 1.0.8

    48. [8wayRun.Com] XenPorta (Portal) 1.5.4

    49. [8wayRun.Com] XenUtiles (Tools) 1.2.1

    50. [bd] Medal 1.3

    51. [bd] Tag Me 1.5.7

    52. [bd] Widget Framework 2.0.6

    53. [dc] Smiley Manager 1.0.0

    54. [InfisJSC] Topic starter's rights 1.2.1

    55. [RT] Custom Sidebar Block 1.1

    56. [tLk] Gender Percent 1.0.0

    57. [tLk] Usergroup Legend 1.0.0

    58. [WMTech] - Maintenance Screen 1.0.1
     
  10. Chris D

    Chris D XenForo Developer Staff Member

    Looking at all of those...

    I suspect it might be Are You A Human if any.

    I will do some testing and let you know.

    Either way, I will work out what the problem is and resolve it whether it be a patch on that add-on and informing the developer or an update on my own.
     
    Robyn Unc Privette likes this.
  11. Robyn Unc Privette

    Robyn Unc Privette Active Member

    Very awesome! Thank you.
     
  12. Chris D

    Chris D XenForo Developer Staff Member

    Interesting. I think I can actually replicate this error.

    It's not a clash.

    It is a bug - sort of.

    Basically, if you make a mistake on the registration form (mismatched passwords, failed captcha, username / email in use etc.) then that's the error you get which is caused by my add-on.

    I am going to rewrite this bit so the following happens after the datawriter has been called. I think that makes more sense.
     
  13. Kenneth Holland

    Kenneth Holland Active Member

    Hi Chris,

    I just noticed I'm getting the same error on registration as well.

    Have you found a fix by chance?

    Ken
     
  14. Chris D

    Chris D XenForo Developer Staff Member

  15. Kenneth Holland

    Kenneth Holland Active Member

  16. Chris D

    Chris D XenForo Developer Staff Member

    Which is an old version. Install the update.
     
  17. Kenneth Holland

    Kenneth Holland Active Member

    I actually disabled it Chris and now I cannot register at all.

    I get:

    A server error occurred. Please try again later.
     
  18. Kenneth Holland

    Kenneth Holland Active Member

    I'll try the update now.
     
  19. Kenneth Holland

    Kenneth Holland Active Member

    I've never updated. How do I do this?
     
  20. Kenneth Holland

    Kenneth Holland Active Member

    I tried upgrading, I get this error:

    Please enter a valid callback method.
     

Share This Page