1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 User profiles aren't showing all of the users posts, rebuild caches only added a few

Discussion in 'Installation, Upgrade, and Import Support' started by Soliloquy, Apr 12, 2016.

  1. Soliloquy

    Soliloquy Member

    The import script brought over the forums just fine, but on the individual user profile pages, the "Postings" tab isn't listing the full amount of everyone's posts. For example, my post count is over 4000, but the Postings tab had about 119. (And not the most recent ones either, it seemed pretty random.)

    I tried rebuilding the thread information and the search indexes for threads, and that did raise my post count a bit to 180. But it's still not where it ought to be.
  2. Mike

    Mike XenForo Developer Staff Member

    If you only built the search index for threads, it's very incomplete. You need to rebuild the full search index.
  3. Soliloquy

    Soliloquy Member

    Okay, I just did that and now the Postings tab has 156 posts. I didn't get any error messages from the rebuild search index tool, so I'm at a loss to explain this.
  4. Mike

    Mike XenForo Developer Staff Member

    The number of results will always be capped by the max search results that you allow. The last page of a member content search will allow you to find older results though. Assuming I've identified the forum and user in question, I can browse through the older results without issue.

    Do you have any add-ons that add content to the search index? In particular, one that indexes conversation messages? That can interfere with general searches to a degree.

Share This Page