1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 User Accounts all showing "No"

Discussion in 'Troubleshooting and Problems' started by racingtrader, Nov 22, 2015.

  1. racingtrader

    racingtrader Member

    I have set each user group permissions, Admin, Super Mod, Registered User etc and then selected that setting for each user but when I go back and pick the user its showing all settings as "NO"
     
  2. racingtrader

    racingtrader Member

  3. Brogan

    Brogan XenForo Moderator Staff Member

    User permissions will show as not set unless you specifically apply them to the user.
    Permissions are inherited from the user groups.

    Use the permissions analyser if you want to check permissions.
     
  4. racingtrader

    racingtrader Member

    Should I have to apply them to each user if I have already set the permissions for the user group and made user that users main setting is that group?
     
  5. racingtrader

    racingtrader Member

    Think I figured it out, I had "View Nodes" as not set for super moderators and they could not see the forum. I used Kyles account as an example. Thanks.
     
    Last edited: Nov 22, 2015
  6. Tracy Perry

    Tracy Perry Well-Known Member

    Uhhh. think you already made a major mistake if you are saying what I think you are saying... you don't make ANY group other than registered the primary group. To do it any other way is not following the philosophy in how the groups/perms were designed.
    I strongly recommend you reading Brogans guide on implementing permissions.
     
  7. racingtrader

    racingtrader Member

    My primary group is "registered", my issue was seeing all of the options set to "not set" when viewing a individual profile. but his primary was set to registered and those rules took affect. I had changed my super moderator setting to not view nodes by mistake and that is where the issue started when they could not see the forums and I started looking around and noticed member profiles all saying "not set" when really they were by the user groups.
     
  8. Tracy Perry

    Tracy Perry Well-Known Member

    Good deal.. what concerned me was my understanding of your
    statement. Frequently new users of XenForo will make the mistake of trying to shoehorn how they were used to doing permissions to work in XF and then have issues.
    Sounds like you've got a decent grasp on it! Good on ya'!
     
  9. racingtrader

    racingtrader Member

    Still very new to everything the mistakes will be coming lol.
     

Share This Page