• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.1 Url Redirection

#1
Hi Guys,

I have installed Xenforo inside the folder name" Forum" in my Root folder of my hosting. I also don't have any Home forum yet as i planned to Install Xenporta for the Home page. However, when i have done with the installation. I just know that when i enter my domain on the web browser, ex: http://myforum.com, it is not transfer to my Xenforo forum, even using Xenporta and all my Root document on the host is appeared in the main page, except if i enter: http://myforum.com/forum then it will appear my Xenforo forum.

At the moment, i have to use the Domain Redirection on my Hosting to forward my domain to: http://xxxxx/forum. So, i woulk like to ask if you guys know how to set the my Forum like this: I just need to type: http://myforum.com on the web browers the it will appear http://myforum.com or http://myforum.com/home... for the Xenporta and when i click on "Forum" tab, the Url will become like: http://myforum.com/forum.... ?

Really appreciate if anyone can help me on this.
 

Jake Bunce

XenForo moderator
Staff member
#2
I don't think XenPorta supports being outside of the forum directory. I suggest installing XenForo (and XenPorta) in your web root. Do away with the /forum directory. Then you won't need to redirect anything.
 
#3
I also try to install in into the Root, but there is no such of link: http://myforum.com/forum when i click on "Forum" tab (as "forum" is the name of the folder that will be appear when u install Xenforo into it on the Roort of ur hosting). It was only appeared like " http://myforum.com/index.php.... " when i click on the "Forum" Tab.

Kindly assist on this. Thanks
 
#4
I also try to install in into the Root, but there is no such of link: http://myforum.com/forum when i click on "Forum" tab (as "forum" is the name of the folder that will be appear when u install Xenforo into it on the Roort of ur hosting). It was only appeared like " http://myforum.com/index.php.... " when i click on the "Forum" Tab.

Kindly assist on this. Thanks
use FULL Friendly.. That option allow u remove index.php
 
#5
xenporta options - set as index controller
xenforo - options - basic board info - homepage url - leave this field blank

I had to logout of the front page in order to see the effects