1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Urgent - Please Help. Thanks,

Discussion in 'Troubleshooting and Problems' started by Gopala Subramanium, Oct 16, 2012.

  1. Gopala Subramanium

    Gopala Subramanium Active Member

    My site (www.FixMyStuff.In) has been excessively slow for the past few days and I get 500 Internal Server error very often.

    I'm hosted with Godaddy. I got in touch with the host many a times but they say that things are absolutely fine at their end.:cry:

    Can anyone please check this let me know any solution please?

    Thanks a ton in advance.
     
  2. Digital Doctor

    Digital Doctor Well-Known Member

    Have you changed anything lately ?
    Post the server logs ?
     
  3. Gopala Subramanium

    Gopala Subramanium Active Member

    I don't remember doing any major changes.

    Server Logs attached for your reference.

    Thanks,
     

    Attached Files:

  4. D.O.A.

    D.O.A. Well-Known Member

    Jake Bunce likes this.
  5. ENF

    ENF Well-Known Member

    This looks to be a problem:

    [Tue Oct 16 03:39:46 2012] [warn] [client <removed>] mod_fcgid: read data timeout in 120 seconds
    [Tue Oct 16 03:39:46 2012] [error] [client <removed>] Premature end of script headers: index.php

    You may wan to try disabling your addons first to see if the problem persists. 2 minutes is a long time to load a script.

    Do you have a lot of addons?
     
    Jake Bunce likes this.
  6. Gopala Subramanium

    Gopala Subramanium Active Member

    Thanks. Yes, I do have a lot of add-ons. Can you give me an idea as to which add-on is giving this problem? This will be really helpful. Thanks,
     
  7. ENF

    ENF Well-Known Member

    The best way to do this is just to disable the addons all at once and see if performance changes.

    a) if the performance changes, then it's likely caused by an addon.
    b) if the performance does not change, then it's likely a server or database issue.

    Add this line to your config.php to temporarily disable the addons. Remove this line after you're done testing.
    Code:
    $config['enableListeners'] = 0;
    
     
    Jake Bunce and Chris D like this.
  8. ENF

    ENF Well-Known Member

    After you've done the above and determined it's an Addon issue, list your addons here and then we can see if any of them have been identified as a troublemaker.

    If it's not addon related, then that's a whole other path to go down.
     
    Jake Bunce and Chris D like this.
  9. Gopala Subramanium

    Gopala Subramanium Active Member

    Thanks ENF & DOA. I disabled all the add-ons have enabled a few important ones and seems to be a little better now. Let me monitor this for some time, will get back to you all incase i need further help. Thankyou so much for such quick help.
     

Share This Page