URGENT! Forums redirect to subdomain, don't want them to, remove redirect, forums won't work.

Izagar

Active member
#1
Edit 3: Disregard... I've finally fixed it ._.

Okay, first, I'm unsure if this is the right board. Please move it to the appropriate board mods. Thanks. :)

Second, this is irritating me. Hence the "urgent" in the title. I gave a basic idea what's happening in the title, but I'll explain more in the post.

My site just moved and the forums were on a subdomain at: http://forums.zelda-sanctuary.net. Going to http://zelda-sanctuary.net/forums goes to the subdomain. Well by doing THAT, I CAN'T ACCESS THE BOARDS. Like this one: http://forums.zelda-sanctuary.net/forums/zelda-sanctuary.55/ because it redirects it to http://forums.zelda-sanctuary.net/zelda-sanctuary.55/ -_-;;

If I remove the redirect, you can't login. If I remove the subdomain, you can't access the forums.

What to do? @_@

My .htaccess file in /forums/

Code:
#	Mod_security can interfere with uploading of content such as attachments. If you

#	cannot attach files, remove the "#" from the lines below.

#<IfModule mod_security.c>

#	SecFilterEngine Off

#	SecFilterScanPOST Off

#</IfModule>



ErrorDocument 401 default

ErrorDocument 403 default

ErrorDocument 404 default

ErrorDocument 500 default



<IfModule mod_rewrite.c>

	RewriteEngine On



	#	If you are having problems with the rewrite rules, remove the "#" from the

	#	line that begins "RewriteBase" below. You will also have to change the path

	#	of the rewrite to reflect the path to your XenForo installation.

	#RewriteBase /xenforo



	#	This line may be needed to enable WebDAV editing with PHP as a CGI.

	#RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]



	RewriteCond %{REQUEST_FILENAME} -f [OR]

	RewriteCond %{REQUEST_FILENAME} -l [OR]

	RewriteCond %{REQUEST_FILENAME} -d

	RewriteRule ^.*$ - [NC,L]

	RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]

	RewriteRule ^.*$ index.php [NC,L]

</IfModule>
My .htaccess file in the main directory:

Code:
Redirect /forums http://forums.zelda-sanctuary.net

# BEGIN WordPress

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress
Wordpress isn't doing nothing to it. Never has done anything to it. Just the /forums/ in the url disappear.

Edit: Okay, there's more issues as much server isn't giving me the proper permissions... THAT I have to wait for my host to resolve it.

Edit2: Moving the forums to "forum" also resulted in weird things.
 
Top