• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Uploading a file to forums - error

#1
I just changed the specifications on uploading files. I set it the file limit to 100MB (highest file i have is 60 MB). When i try to upload the file, it gets to 100% then gives me an error that says "There was a problem uploading your file." I also added the extension .exe, so I shouldn't have a problem. I don't understand whats wrong? I even tried it with a 10MB file, still experiencing the same error. However, the 3MB file worked.
 
#3
Okay thanks i'll take a look at it. I just wanted to put a couple files up, as I'm waiting for the Downloads mod to come out soon. Thanks brogan
 
#6
My php.ini path says this:

Configuration File (php.ini) Path= " /etc "

However, when i go to the 'etc' folder, there is no php.ini file in there, even if i show hidden files?

I have a file named 'ftpquota' and a 'worldofdiscussions' folder, and thats all.
 

Jake Bunce

XenForo moderator
Staff member
#11
You can only access /etc as root. If you are on a dedicated or VPS server then you should have root access. For other types of servers like shared servers you don't get that level of access and cannot edit the PHP configuration.
 

Jake Bunce

XenForo moderator
Staff member
#13
You can't access the php.ini file on a shared server.

You can try changing your PHP settings by editing the library/config.php file in XF. You can use code like this:

Code:
ini_set('name_of_setting', 'value');
This works sometimes. But some hosts don't allow this.