XF 2.2 Uploaded file size is too large - All settings correct

DaveL

Well-known member
Afternoon!
Trying to upload a ZIP file as an attachment in the Resource Manager. File size is 70.6MB.

My server allows 500MB and this is confirmed on the admin dashboard and also on the attachment size page.

at1.png
at2.png

However when I try to upload the file, it gets to 100% and then displays this error
at3.png

Any help appreciated, as this is the main reason I set my forum up!
 

DaveL

Well-known member
You have to change the correct php.ini file. See what version of php you are using and change it there.
Runnning PHP 7.2.33.

In my PHP.ini I have

; Maximum allowed size for uploaded files.
upload_max_filesize = 500M

and

; Maximum size of POST data that PHP will accept.
post_max_size = 500M

This updated straight away on the XF admin dashbooad and attatchement file size page.
 

DaveL

Well-known member
What do the server logs say? Seems to me the file is taking too long and timing out. What is it that's so big? Can't you use ftp?
Nothing showing in the the server logs. It's a 70MB zipped file. The purpose of my site is for people to be able to share files of similar or slightly higher size.
 

Kirby

Well-known member
post_max_size and upload_max_filesize seem fine to me.

What about upload_tmp_dir, does that have enough free space?

Did you double check permissions?
 

DaveL

Well-known member
Funny thing is, I can upload the same file to a forum post with no issues. It's only when uploading it via the Resource Manager I get this issue.
 

DaveL

Well-known member
post_max_size and upload_max_filesize seem fine to me.

What about upload_tmp_dir, does that have enough free space?

Did you double check permissions?

Just checked in php.ini and this is what it says:

; Temporary directory for HTTP uploaded files (will use system default if not
; specified).
;upload_tmp_dir =

Just looked at usergroup permissions, couldn't see anything relating to the RM.
 

Kirby

Well-known member
I was talking about Resource Manager permissions /options / category settings, not PHP configuration.

If upload_tmp_dir is undefined it will use system default (usually /tmp).
As forum uploads do work fine it is unlikely that you are running out of space there.

It seems pretty obvious to me that you've got a lower limit configured for XFRM somewhere (most likely permission, option or category setting) - unfortunately I can't tell where exactly as I do not have access to XFRM.
 
Top