1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Upload problem after migration

Discussion in 'Installation, Upgrade, and Import Support' started by drifter4ever, Dec 6, 2013.

  1. drifter4ever

    drifter4ever Member

    I have just migrated from vBulletin to Xenforo, but some users can't upload attacments (attacment is below the limit 2 MB), others can. This seems to happen randomly, how is it possible and what can I do to fix it?

  2. drifter4ever

    drifter4ever Member

    I was told that choosing "stay logged in" helped, then upload was possible and the user didn't get logged out while uploading. Something strange anyway. Is it possible to have "stay loggen in" as default?
  3. Mike

    Mike XenForo Developer Staff Member

    Staying logged in would just be a template tweak to the login_bar_form and helper_login_form templates (I believe).

    However, I believe that error indicates an unknown error. Often, it can indicate a lost connection between the client and the server when uploading (such as the server terminating the connection). I have heard that Flash can be a little less consistent with this than the standard non-Flash uploader, though I've not had any problems with it personally. Alternatively, there could be a limit on your server (mod_security?), though I think that would consistently block the upload.
  4. drifter4ever

    drifter4ever Member

    I disabled Flash uploader and caching sessions (with xcache) and after that I do not have problems with uploading or keeping logged in (without using "stayed logged in". But how much slower does disabling sessions cache make my site?
  5. Mike

    Mike XenForo Developer Staff Member

    Well, point number one should really be "does it work" rather than "is it fast". A fast, broken system doesn't really serve any purpose. :)

    But regardless, the difference is unlikely to be perceptible.
    Amaury and drifter4ever like this.

Share This Page