1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Upload Multiple Images - attachment_upload_button

Discussion in 'XenForo Development Discussions' started by Bugfix, May 27, 2015.

  1. Bugfix

    Bugfix Member

    I implemented the attachment_uploader (attachment_upload_button) for my own conent_type-
    However, I can only select one image. Same XF-code unter conversations I can select multiple images.
    I cannot find any differences. Is this a setting in the Attachment-Constraints I'm overlooking? Or is this a JS-topic?
    Please give me a hint!
  2. Bugfix

    Bugfix Member

    got it: $xenOptions.swfUpload is not "true" - for whatever reason
  3. Bugfix

    Bugfix Member

    Can anyone tell me why "xenOptions" isn't set in my template-modification? Where is this set?
    I had to do:
    $xenOptions['swfUpload'] = XenForo_Application::get('options')->swfUpload;
    $viewParams = array('xenOptions' => $xenOptions);
  4. Jake B.

    Jake B. Well-Known Member

    Template modifications are compiled into the template so they should be available unless you're doing a template modification on a template that is being loaded in an odd manner.
  5. Bugfix

    Bugfix Member

    well, they don't...
    I do the mod/extension with an addon & Event-Listeners
  6. NixFifty

    NixFifty Well-Known Member

    You shouldn't even need to pass that to your template. {$xenOptions} is available globally. Use {$xenOptions.swfUpload} to get the value of that specific option.
  7. Bugfix

    Bugfix Member

    Yes. Exactly that is the question! Please see my second post:
    {$xenOptions.swfUpload} is not "true" - it is not filled in my template! (In settings it is enanbled of course!

Share This Page