Upload & Host Images on your forum using Add.Pics for Free

Upload & Host Images on your forum using Add.Pics for Free 1.0.8

No permission to download

Faust

Well-known member
Open PAGE_CONTAINER template

Add this code above </head>
Code:
<xf:if is="$xf.visitor.user_id AND in_array({$template}, ['forum_post_thread', 'conversation_add', 'conversation_view', 'thread_view', 'post_edit', 'forum_view', 'xfmg_media_view'])">
   <script async src="https://add.pics/sdk/pup.js?_v=3152" data-url="https://add.pics/upload" vendor="xenforo"></script>
</xf:if>

It's just same issue.

Anyway, It's fine. just uninstalled the addon as need to do some clearing un unneeded addons.

Screenshot 2020-09-23 130347.png
 
It was working until yesterday. Since I updated to 2.2, button got disappeared. Before it was besides the preview button. Now preview button as well disappeared same like this page. Only Post reply button is there now.
 
Hello. Tell me please.
How do I create the BB button itself to open the image upload? I do not need the button below the "answer" button. How can I fix it? In the description you have such button BB, but it is not visible after installation, except the button "Upload image". I use XF 2.2.0. The plugin itself works perfectly. Thank you for the adaptation. But the visual part is not attractive because of the problem with the BB button output. Reminds me of the Imgur analogue on reddit.

And another question. Is it possible that when Gif is loaded, it can be played in a message instead of opening it and switching to the add.pics? Because many photo exchanges do not have this problem.
 
Last edited:
A critical bug for version 2.2 was detected. It is contraindicated to use the plugin until the author fixes the problem.

The problem is that nothing can be uploaded through the button "Attach files". In the panel BB when you select to upload images disappears the ability to upload locally and leaves the download only through a link that also does not work. If you load another file at that, the error repeats.

If you clear the cookies, the problem passes and the images are loaded, but if you refresh the page, the problem appears again. I checked the bug on the local server during the new XF 2.2.0 installation and it's the same there.

I can assume that file download paths intersect in the same class as this plugin, which leads to a conflict between local downloads.

The browser console reports this error:
Code:
Failed to load resource: the server responded with a status of 404 ()
Failed to load resource: net::ERR_BLOCKED_BY_CLIENT

Screen Shot 10-04-20 at 06.11 PM.PNG
 

TCGMook

Active member
Just coming in here to say this has been a LIFESAVER on my site. It gets so much use. If you ever plan on shutting down hosting, PLEASE message me prior. My members use it extensively.
 

Add.Pics

Member
How do I create the BB button itself to open the image upload?
More advance option is here:
Is it possible that when Gif is loaded, it can be played in a message instead of opening it and switching to the add.pics?
Yes, you can choose to embed the full image.
You can achieve that by using BBCode full linked:

The browser console reports this error
This is known bug between Chevereto PUP and XF 2.2.x unfortunately, hopefully bug fixed is coming soon.
 

Add.Pics

Member
How to disable upload button in a partculat category or forum?
@Add.Pics is there a way to disable upload button in conversations?
Both, you can use XenForo conditionals with that.

Just coming in here to say this has been a LIFESAVER on my site. It gets so much use. If you ever plan on shutting down hosting, PLEASE message me prior. My members use it extensively.
That's awesome and we DON'T have any plan on shutting down.
We use it extensively on several forums also.
 
Top