• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Fixed "Upload a File" button in iOS9

rellect

Well-known member
#1
When editor is in focus and keyboard is visible, occasionally I cannot click on "Upload a File" button.
This only started after upgrading to ios 9.0.2.
 

EQnoble

Well-known member
#2
When you say you cannot click, do you mean it is not there, greyed out (unavailable),button as normal but can't be clicked etc etc?

Just on a hunch and pending your answer to the question above I would suggest switching to the default xf style and see if you can replicate it if you have not already.
 

rellect

Well-known member
#5
Does this happen here? I can't reproduce it at the moment.
Yes I can reproduce it here. I think it may be related to how quickly you tap.
I noticed that when I quickly tap, the button will be pressed. But if I tap and hold for 400ms~ before I lift my finger, it won't work.
 

Chris D

XenForo developer
Staff member
#6
Do you see the blue caret flashing when it fails to action? I'm wondering if it's related to the editor being focused.
 
#8
Safari on iOS blows - it is quite buggy. The same thing happens in Wordpress when you are using certain themes - the "Read More" button no longer functions properly. You tap on it and nothing happens. We have found that certain css styles break anchor tags on iOS Safari. Stupid, I know. To get the "Read More" button on our Wordpress working again on iOS we've had to disable some shadow css styling. Something similar is probably happening here.
 

Chris D

XenForo developer
Staff member
#9
It's actually not something we've been able to reproduce at the moment.

@rellect can you provide any more detailed reproduction steps? Which iOS version? Which device etc?
 

rellect

Well-known member
#11
It's actually not something we've been able to reproduce at the moment.

@rellect can you provide any more detailed reproduction steps? Which iOS version? Which device etc?
I'm curretly on 9.2.0 (iphone 5) and the bug here is rarely happens now.

The steps are quite simple:
1. Create a new thread
2. Write something
3. While keyboard is still visible, click on Upload a File

This may require a physical device running ios9 to test on. But as I mentioned, after upgrading to 9.2 it's now rarely happens.

There is similar issue with the popup to upload files though. I usually cannot click on the 'close' button, I attached screenshots.
 

Attachments

Chris D

XenForo developer
Staff member
#12
I had only been testing it on the quick reply, to be honest.

Maybe that's why I couldn't reproduce it, I will take another look, thanks for the additional info :)
 

Chris D

XenForo developer
Staff member
#13
I've still been unable to reproduce the originally reported issue, but we have made changes here specifically to fix the close button issue and I reckon this will generally help.

We now specifically blur the editor when the "Upload a File" button is clicked.

We'll roll this out here shortly if you'd like to test :)

Thanks.