• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Upgrading from vB 3.08 to xenForo

#1
I understand that there are import scripts to go from newer versions of vB to XF.

Just wondering if the 3.x import script supports vB 3.08?
If not, any guess-estimates about how difficult it would be to modify the script to make it possible?
Is the import script mainly an sql script?
 
#4
Sorry, Michael...

I misread your VB version... I also asked the same question whether 3.0.x can be imported by default.

If not, then you can upgrade your VB 3.0.x software to 3.6 for free at VB, then use the Xenforo importer.
 

Digital Doctor

Well-known member
#5
Sorry, Michael... I misread your VB version... I also asked the same question whether 3.0.x can be imported by default. If not, then you can upgrade your VB 3.0.x software to 3.6 for free at VB, then use the Xenforo importer.
Seems like the best method would be upgrade 3.0.8 to 3.6 or 3.8 and then upgrade xenforo.
or
downgrade 3.0.8 to vB 4.x, realize vB sucks, and then upgrade vB4 to xenforo 1.1.
 

Brogan

XenForo moderator
Staff member
#7
If there have been any schema (DB structure) changes from vB 3.0.8 to 3.6/7/8, which is highly likely, then the import will not (fully) succeed.

You will need to upgrade to a compatible version before importing into XenForo.
 
#8
If there have been any schema (DB structure) changes from vB 3.0.8 to 3.6/7/8, which is highly likely, then the import will not (fully) succeed.
You will need to upgrade to a compatible version before importing into XenForo.
Thanks for the reply. I guess I will just have to research what schema changes where made between the versions of vB; and see if I can just mod the database to slog through the conversion process. :)
 
#9
Thanks for the reply. I guess I will just have to research what schema changes where made between the versions of vB; and see if I can just mod the database to slog through the conversion process. :)
Hi Michael...

Since Xenforo has a default built-in VB 3.6 to XF importer, and upgrading your VB software from 3.0.8 to 3.6 is free, then why not upgrade your VB and then import?
 

Jake Bunce

XenForo moderator
Staff member
#10
Yeah. Upgrade the database to vB 3.6. Then you are good to go for the import. 3.0 to 3.6 is an easy upgrade. I can help with the upgrade if you are having trouble.

I guess I will just have to research what schema changes where made between the versions of vB; and see if I can just mod the database to slog through the conversion process. :)
Don't do that.