• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.4 Upgrades randomly not working

JamesBrown

Well-known member
#1
I'm getting a few instances where upgrades are purchased but not applied. It's not happening all the time some upgrades work fine.

I am also getting some emails from PP and wonder if this might have anything to do with it.

Thanks

Dear ..,

Please check your server that handles PayPal Instant Payment Notification (IPN) messages. Messages sent to the following URL(s) are not being received:

http://www.xxxxx.co.uk/payment_gateway.php?method=paypal

If you do not recognize this URL, you may be using a service provider that is using IPN on your behalf. Please contact your service provider with the above information.

Once you or your service provider fix this problem, you or your service provider can resend the failed messages from the IPN History page. If this problem continues, PayPal may disable the IPN feature for your account.

Thank you for your prompt attention to this issue.

Yours sincerely,
PayPal
 

Mike

XenForo developer
Staff member
#2
That email is not a XenForo URL -- it's presumably related to upgrades from your previous software. Assuming you have recurring subscriptions from before, you'll need to cancel those in PayPal.

Otherwise, in terms of the users not being upgraded, please check the upgrade transaction log to see if there are any "error" entries.
 

JamesBrown

Well-known member
#3
Hi @Mike Thanks I just checked the xF transaction log and the last entry was on Monday. Yet according to Paypal I've had over 30 subscribers since then, none whom have been upgraded. :confused:
 

Mike

XenForo developer
Staff member
#4
That might be PayPal disabling IPNs as they mention in that email (but as the listed URL isn't XF related, there isn't something we can do about it). You could try re-enabling IPNs, but I'm not sure if they'll retroactively resend them.