• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Upgrades not listed under purchase list after payment completion

#1
I have created upgrades for users .After payment paid users not listed in active upgrates.can any one help me.how to solve this?
 

Brogan

XenForo moderator
Staff member
#2
Please ensure you post in the correct forum.

This is not a development discussion, I have moved it to questions and support.
 
#4
I have paid the amount via sandbox for user upgrades .payment process successfully created but still
upgrade listed in available upgrade .upgrades not working correctly.how to solve this?
 

Brogan

XenForo moderator
Staff member
#5
Please do not post the same thread multiple times - this is the fourth thread now.

Post all of the details as to what you have done.

Check the ACP error logs.

Disable any add-ons and try again.
 

Jake Bunce

XenForo moderator
Staff member
#6
Check the xf_user_upgrade_log table. Is there any record of the transaction? The record may contain a specific error message if there was a problem. If there is no record of the transaction then make sure the payment completed (in your paypal account). Also check these things:

1) Make sure your board URL is correct:

Admin CP -> Home -> Options -> Basic Board Information -> Board URL

2) Note that the paypal callbacks don't work if your forum is behind a htaccess login.

Or it's possible Paypal simply failed to send the callback. That happens sometimes in which case you can manually upgrade the user in the Admin CP.
 

Jake Bunce

XenForo moderator
Staff member
#9
Checked the xf_user_upgrade_log table no entries .
That means no payment callbacks have been received from Paypal. That is the problem.

I would refer back to my previous post:

...if there is no record of the transaction then make sure the payment completed (in your paypal account). Also check these things:

1) Make sure your board URL is correct:

Admin CP -> Home -> Options -> Basic Board Information -> Board URL

2) Note that the paypal callbacks don't work if your forum is behind a htaccess login.

Or it's possible Paypal simply failed to send the callback. That happens sometimes in which case you can manually upgrade the user in the Admin CP.
 

Mike

XenForo developer
Staff member
#10
And you need to ensure that you followed the instructions when listing the PayPal account in XF:
This is the primary email address on your PayPal account. If this is incorrect, payments may not be processed successfully. Note this must be a PayPal Premier or Business account and IPNs must be enabled. Please see our help.