1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.3 upgrade issues

Discussion in 'Installation, Upgrade, and Import Support' started by MITK, Mar 20, 2014.

  1. MITK

    MITK Member

    Running XenForo 1.3.0 Beta 3

    Trying to upgrade to the latest version of 1.3

    Uploaded all the upgrade files and chmod 0777 to the data and internal_data, all sub dir and files below that

    When I go to the site I see an "upgrade in progress" and when I got to the install directory I get an 500 Internal Server Error (copied below)

    Now the interesting thing, when I do a restore on the files only in forum it starts working again.

    Any ideas?

    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, webmaster@ and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    Can you check the server error log and post the contents here?
     
  3. MITK

    MITK Member

    This is really the only thing in the error log


    [Thu Mar 20 04:35:31 2014] [error] [client MY IP] SoftException in Application.cpp:601: Directory "/home/....../public_html/forums/install" is writeable by group
    [Thu Mar 20 04:28:29 2014] [error] [client MY IP] SoftException in Application.cpp:601: Directory "/home/....../public_html/forums/install" is writeable by group
    [Thu Mar 20 04:27:59 2014] [error] [client MY IP] SoftException in Application.cpp:601: Directory "/home/....../public_html/forums/install" is writeable by group
    [Thu Mar 20 04:27:55 2014] [error] [client MY IP] SoftException in Application.cpp:601: Directory "/home/....../public_html/forums/install" is writeable by group
    [Thu Mar 20 04:22:05 2014] [error] [client MY IP] SoftException in Application.cpp:601: Directory "/home/....../public_html/forums/install" is writeable by group
    [Thu Mar 20 04:22:05 2014] [error] [client MY IP] SoftException in Application.cpp:601: Directory "/home/....../public_html/forums/install" is writeable by group
    [Thu Mar 20 04:22:04 2014] [error] [client MY IP] SoftException in Application.cpp:601: Directory "/home/....../public_html/forums/install" is writeable by group
    [Thu Mar 20 04:22:04 2014] [error] [client MY IP] SoftException in Application.cpp:601: Directory "/home/....../public_html/forums/install" is writeable by group
    [Thu Mar 20 04:22:04 2014] [error] [client MY IP] SoftException in Application.cpp:601: Directory "/home/....../public_html/forums/install" is writeable by group
    [Thu Mar 20 04:22:04 2014] [error] [client MY IP] SoftException in Application.cpp:601: Directory "/home/....../public_html/forums/install" is writeable by group
    [Thu Mar 20 04:22:03 2014] [error] [client MY IP] SoftException in Application.cpp:601: Directory "/home/....../public_html/forums/install" is writeable by group
    [Thu Mar 20 04:22:02 2014] [error] [client MY IP] SoftException in Application.cpp:601: Directory "/home/....../public_html/forums/install" is writeable by group
    [Thu Mar 20 04:21:32 2014] [error] [client MY IP] SoftException in Application.cpp:601: Directory "/home/....../public_html/forums/install" is writeable by group
    [Thu Mar 20 04:21:18 2014] [error] [client MY IP] SoftException in Application.cpp:601: Directory "/home/....../public_html/forums/install" is writeable by group

    Its something to do with the files because when i restore the files only thus undoing the upload it starts working again.
     
  4. Mike

    Mike XenForo Developer Staff Member

    You need to change the permissions on the install directory. Set it to 0755.
     
  5. MITK

    MITK Member

    So instead of 777 on both i should do 755 or 777 on data and 755 on install?
     
  6. Brogan

    Brogan XenForo Moderator Staff Member

    General files and directories should be 0644 and 0755 respectively.

    The /data and /internal_data directories should be 0777.
     
  7. MITK

    MITK Member

    That was it Good Sir ... Upgrade has started.

    Thank you
     

Share This Page