XF 2.2 upgrade issue to 2.2

kalvink

Member
I started the upgrade to be told the site is too large and it reccomended updating via cli from the root directory using comand php cmd.php xf:upgrade

The error returned is: PHP 7.0.0 or newer is required. 5.6.40 does not meet this requirement. Please ask your host to upgrade PHP

my current php version is 7.4.10

The forums are closed as the admin portal in gui is reporting that The site is currently being upgraded. Please check back later.

Please could someone point me in the right direction?
 
Solution
You'd need to restore the files back to the ones for the version that you were previously using if you want to undo the steps taken towards the upgrade (provided you haven't started the process yet).

In terms of the CLI upgrade, if you know the path to a more recent version of PHP, you could use that explicitly (rather than php). A command like whereis php might help point to that, if there are multiple in your path.

Brogan

XenForo moderator
Staff member
You need to ensure that the version of PHP which is running against the XF installation is 7.x, not just what is being reported on the server.

That is not always the case, if you have an override set in .htaccess, for example.

Your host will be able to assist with that.
 

Brogan

XenForo moderator
Staff member
You can try adding this to the config.php file:

PHP:
$config['checkVersion'] = false;

But really I would leave the forum disabled until you complete the upgrade.
 

Mike

XenForo developer
Staff member
You'd need to restore the files back to the ones for the version that you were previously using if you want to undo the steps taken towards the upgrade (provided you haven't started the process yet).

In terms of the CLI upgrade, if you know the path to a more recent version of PHP, you could use that explicitly (rather than php). A command like whereis php might help point to that, if there are multiple in your path.
 
Solution

Brogan

XenForo moderator
Staff member
How large is your site in terms of posts, threads, members?

If it's not too big you could try the web server upgrade, but there may be timeouts.

Otherwise as Mike said above, or upgrade the PHP version that CLI sees to 7.x.
 
Top