1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.3 Upgrade Issue please help Urgent!

Discussion in 'Installation, Upgrade, and Import Support' started by PAPPACLART, Jun 21, 2014.


    PAPPACLART Active Member

    Just upgrading my site from 1.3.2 to 1.3.3 and I have this error.

    The following errors occurred while verifying that your server can run XenForo:

    • All directories under /var/www/vhosts/gtarena.com/httpdocs/community/data must be writable. Please change the permissions on these directories to be world writable (chmod 0777).
    Please correct these errors and try again.

    I do not re call having folders var/www/vhosts/gtarena

    As far as I am aware no file permissions have changed. The update from 1.3.1 to 2 was without issue.

    The only thing I did differently this time was use my desktop for the upgrade (first time) and copied the upgrade files directly from the desktop (folder) and dragged them into filezilla, rather than from transferring the files from within filezilla.
    Last edited: Jun 21, 2014

    PAPPACLART Active Member

    Any help gents, site is down. I am currently changing folder permission for all folders but it is taking an age, am I doing the right thing?
  3. Mike

    Mike XenForo Developer Staff Member

    /var/www/vhosts/gtarena... is where your files are.

    But really, you just need to sort out the permissions on the directories (and all other files, if they're not writable) under the data/ directory. Something changed, otherwise you would have gotten this error before (it checks every upgrade). Perhaps you uploaded something into that directory manually?

    PAPPACLART Active Member

    First thing I have done since upgrading from 1.3.1 to 1.3.2. Have not touched any file permissions at all.

    So which specific folder should I 777 as if I do htttp docs and community etc and all sub folders and files it will take like 3 days via ftb. (doing Data now)


    Edit just done the Data folder and all files and it seems to be working.

    Thanks Mike
  5. Brogan

    Brogan XenForo Moderator Staff Member

    The /data and /internal_data directories are the only ones which should be chmod-r 0777.

    PAPPACLART Active Member

    I think I may have cmod too many folders before I fixed it :eek:
  7. Brogan

    Brogan XenForo Moderator Staff Member

    General files and directories should be 0644 and 0755 respectively.

Share This Page