XF 2.2 Upgrade Help

Rusty Snippets

Active member
Upgrading from 2.4 to 2.5 my site crashed with


Warning: require_once(/home/xxxx/public_html/xxxx.com/src/vendor/paragonie/sodium_compat/lib/stream-xchacha20.php): failed to open stream: No such file or directory in /home/xxxx/public_html/xxxx.com/src/vendor/paragonie/sodium_compat/lib/php72compat.php on line 1221

Fatal error
: require_once(): Failed opening required '/home/xxxx/public_html/xxxx.com/src/vendor/paragonie/sodium_compat/lib/stream-xchacha20.php' (include_path='.:/opt/cpanel/ea-php74/root/usr/share/pear') in /home/xxxx/public_html/xxxx.com/src/vendor/paragonie/sodium_compat/lib/php72compat.php on line 1221
 

Brogan

XenForo moderator
Staff member
The errors suggest those two files are either missing from the server, or XF can't read them.

Try extracting them from the zip archive and manually uploading them.
 

Mike

XenForo developer
Staff member
That particular file (src/vendor/paragonie/sodium_compat/lib/stream-xchacha20.php) is new in 2.2.5 (more specifically, from a package we include), so I'm guessing it was missed in the upload somehow. I would try reuploading that specific file but it might be worth redoing the full upload as it isn't clear why this one file wouldn't be there.
 

Mike

XenForo developer
Staff member
Ahh ideally that shouldn't happen then. Can you confirm what version you were upgrading from?

A manual upload should definitely sort it. I would do the full upload though as it's not clear how far the one click upgrade system got.
 

GW2

Member
Today I upgraded from XF 2.2.4 to 2.2.5.

Total time required was :
  • 10 minutes to download a back-up to my home computer
  • 2 minutes to complete the upgrade from the ACP.

No errors encountered; 2.2.5 is working fine.
 
Top