• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.3 Upgrade error

#1
Just uploaded all the files and begin the update, when I got this error message. Any help would be great.

Fatal error: Class 'XenForo_Template_Compiler_Function_CheckedSelected' not found in /home/xxxxx/public_html/library/XenForo/Template/Compiler.php on line 149
 
#5
Funny thing was that not everything uploaded which was why I was getting the errors. I always upload everything in the folder, I guess it was just a hiccup. Thank you both though very much.
 

Brogan

XenForo moderator
Staff member
#6
Which FTP application do you use?
If you run Windows, I recommend WinSCP.
Never use Filezilla, it is notorious for issues such as this.
 

santamo

Active member
#8
After installation v.1.4:

An exception occurred: Argument 3 passed to XenForo_Model_Thread::canVoteOnPoll() must be an array, none given, called in /home/s/sm42/forum.xxa.su/public_html/library/WidgetFramework/WidgetRenderer/Poll.php on line 144 and defined in /home/s/sm42/forum.xxa.su/public_html/library/XenForo/Model/Thread.php on line 1388

  1. XenForo_Application::handlePhpError() in XenForo/Model/Thread.php at line 1388
  2. XenForo_Model_Thread->canVoteOnPoll() in WidgetFramework/WidgetRenderer/Poll.php at line 144
  3. WidgetFramework_WidgetRenderer_Poll->_render() in WidgetFramework/WidgetRenderer.php at line 667
  4. WidgetFramework_WidgetRenderer->render() in WidgetFramework/Core.php at line 396
  5. WidgetFramework_Core->_renderWidgetsFor() in WidgetFramework/Core.php at line 313
  6. WidgetFramework_Core->renderWidgetsFor() in WidgetFramework/Listener.php at line 126
  7. WidgetFramework_Listener::template_post_render()
  8. call_user_func_array() in XenForo/CodeEvent.php at line 58
  9. XenForo_CodeEvent::fire() in XenForo/Template/Abstract.php at line 195
  10. XenForo_Template_Abstract->render() in XenForo/Template/Public.php at line 110
  11. XenForo_Template_Public->render() in XenForo/ViewRenderer/HtmlPublic.php at line 123
  12. XenForo_ViewRenderer_HtmlPublic->renderContainer() in XenForo/FrontController.php at line 618
  13. XenForo_FrontController->renderView() in XenForo/FrontController.php at line 158
  14. XenForo_FrontController->run() in /home/s/sm42/forum.xxa.su/public_html/index.php at line 13
 

Amaury

Well-known member
#9
There are some errors in there having to do with the add-on Widget Framework. Post in its dedicated support thread for support with it.