1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Upgrade doesn't want to upgrade...

Discussion in 'Installation, Upgrade, and Import Support' started by reg@TO, Mar 29, 2013.

  1. reg@TO

    reg@TO Member

    I have tried upgrading to 1.1.4 several times now and every time, instead of upgrading, the install routine wants to install a fresh system, as if my forum doesn't even exist. No errors, just goes right to the "your system meets the requirements, we're ready to begin the installation" (or something like that) prompt.

    Any ideas what I'm doing wrong.
  2. Dodgeboard

    Dodgeboard Well-Known Member

    Did you download the UPGRADE package, or the full package?
  3. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Try going directly to install/index.php?upgrade/

    If that doesn't work then you probably overwrote the internal_data directory with the internal_data/install-lock.php file. You can recreate that file to enable the upgrade option, but in that situation you should be concerned about possibly having overwritten other important files like the avatars and attachments which are stored in data and internal_data.
    Dodgeboard likes this.
  4. Dodgeboard

    Dodgeboard Well-Known Member

    If you have a 'files' backup, restore from backup (overwrite), reupload the UPGRADE package (overwrite), and start the install script again.
  5. reg@TO

    reg@TO Member

    Thanks for the response. I did download the upgrade package. I re-downloaded it twice just to make sure. I did try going to install/index.php?upgrade/ and it gave me a slew of errors. The internal_data directory appears to be intact although a new file (at least according to file dates), index.html, appears in it's temp directory. That file is empty.

    I have restored my system from a backup again and am going to try one more time.
    Dodgeboard likes this.
  6. reg@TO

    reg@TO Member

    So I re-downloaded the upgrade package. Then uploaded it and went to /install/. It then told me that my system was already installed. I then went directly to install/index.php?upgrade/ as instructed by Jake. It worked. My system is now upgraded and working fine. The only thing I did different this time as compared to my earlier attempts was that I downloaded and used FileZilla instead of my Coda 2 to upload the files. I don't see how that would make a difference but apparently it did. Thanks to you guys for helping me out.
    Dodgeboard likes this.
  7. Dodgeboard

    Dodgeboard Well-Known Member

    Thanks for the update! Cheers
    reg@TO likes this.

Share This Page