• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.1 Updating to 1.1.4 Error

#1
Hello, I get this error after I updated to 1.1.4



Code:
Declaration of TMS_Model_Template::fetchAllKeyed() should be compatible with that of XenForo_Model::fetchAllKeyed()
 
XenForo_Application::handlePhpError() in XenForo/Autoloader.php at line 119
XenForo_Autoloader::autoload() in XenForo/Autoloader.php at line 119
XenForo_Autoloader->autoload() in XenForo/Application.php at line 872
XenForo_Application::autoload() in XenForo/Application.php at line 411
XenForo_Application::resolveDynamicClass() in XenForo/Model.php at line 189
XenForo_Model::create() in XenForo/Controller.php at line 101
XenForo_Controller->getModelFromCache() in XenForo/ControllerAdmin/Home.php at line 26
XenForo_ControllerAdmin_Home->actionIndex() in EnableDebugFromAdminHome/ControllerAdmin/Home.php at line 7
EnableDebugFromAdminHome_ControllerAdmin_Home->actionIndex() in XenForo/FrontController.php at line 310
XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 132
XenForo_FrontController->run() in /home/metrovil/public_html/community/admin.php at line 13
 

Jake Bunce

XenForo moderator
Staff member
#2
Two addons are referenced in that error:

TMS
EnableDebugFromAdminHome

Contact their authors, or try disabling those addons.
 

tyteen4a03

Well-known member
#4
Enable Debug from Admin Home is fine (I use it and there hasn't been any problems), it's TMS that is causing the error.

Update TMS to fix the issue.