1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.3 Updating templates

Discussion in 'Troubleshooting and Problems' started by Bob_R, Aug 27, 2014.

  1. Bob_R

    Bob_R Active Member

    I have this message in my AdminCP:

    This template is outdated. It is recommended that you merge the parent changes into this template.

    When I click View Custom Changes I get the code and some is in a green shaded area/box and some code is in a reddish shaded area/box.

    Which is the code to add or delete?

    Hope I've explained myself correctly?

  2. Chris D

    Chris D XenForo Developer Staff Member

    View Custom Changes shows you the content that you have added in green and content you have removed in red. If you have to manually merge your changes, this is useful.

    But there is another way of merging. If you click on the "merge the parent changes" link in the message on the template, and look down the list of templates, you will see "Merge Changes". Click that. As long as a few conditions are met, it should be possible to merge your current version of the template with the new parent version of the template.
  3. Bob_R

    Bob_R Active Member

    I get this when I do what you suggested in your 2nd paragraph.


    The custom template is out of date but has been edited more recently than the parent. Merging can only be done by hand.
  4. Tracy Perry

    Tracy Perry Well-Known Member

    Then you need to make note of the template edits that you have made (save them to a text editor) then revert the template and place the edits back in.
  5. Bob_R

    Bob_R Active Member

    I didn't make any edits to templates. I haven't touched a thing. It's a theme I just installed.
  6. Chris D

    Chris D XenForo Developer Staff Member

    The author of that theme will have edited some templates. The author of the theme should be able to provide some specific help.
  7. Tracy Perry

    Tracy Perry Well-Known Member

    As Chris says, the style has template edits done to it by the author... and it's probably not fully compatible with the version of XenForo you are running.
    One option (if it is supposed to be compatible) is to export it (your custom child style), then delete the style (your custom child style) and import it back again. BUT before doing this you need to back up (and confirm the backup) your DB and forum file structure.
  8. Bob_R

    Bob_R Active Member

    Thanks guys.

Share This Page