• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.2 Update to 1.2.5 -

#1
Hi, I wen to upgrade our forum to 1.2.5 but now we are stuck without being able to complete the update. Ftp'd files successfully etc. I think it has something to do with one of the add ons we have

Server Error
Mysqli statement execute error : Duplicate entry '592-2' for key 2
  1. Zend_Db_Statement_Mysqli->_execute() in Zend/Db/Statement.php at line 297
  2. Zend_Db_Statement->execute() in Zend/Db/Adapter/Abstract.php at line 479
  3. Zend_Db_Adapter_Abstract->query() in Zend/Db/Adapter/Abstract.php at line 632
  4. Zend_Db_Adapter_Abstract->update() in XenForo/Model/StyleProperty.php at line 2366
  5. XenForo_Model_StyleProperty->importStylePropertiesFromArray() in XenForo/Model/StyleProperty.php at line 2270
  6. XenForo_Model_StyleProperty->importStylePropertyXml() in XenForo/Model/StyleProperty.php at line 2203
  7. XenForo_Model_StyleProperty->importStylePropertyDevelopmentXml() in XenForo/Deferred/ImportMasterData.php at line 26
  8. XenForo_Deferred_ImportMasterData->execute() in XenForo/Deferred/Atomic.php at line 61
  9. XenForo_Deferred_Atomic->execute() in XenForo/Model/Deferred.php at line 252
  10. XenForo_Model_Deferred->runDeferred() in XenForo/Model/Deferred.php at line 386
  11. XenForo_Model_Deferred->_runInternal() in XenForo/Model/Deferred.php at line 312
  12. XenForo_Model_Deferred->runByUniqueKey() in XenForo/Install/Controller/Abstract.php at line 34
  13. XenForo_Install_Controller_Abstract->_manualDeferredRunner() in XenForo/Install/Controller/Upgrade.php at line 216
  14. XenForo_Install_Controller_Upgrade->actionRunDeferred() in XenForo/FrontController.php at line 347
  15. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
  16. XenForo_FrontController->run() in D:/inetpub/vhosts/DOMAIN/httpdocs/forums/install/index.php at line 18
Any ideas on how to get past this one? I've got a few more sites to upgrade and glad I did my own forum first, before my company forum this time!
 

Mike

XenForo developer
Staff member
#2
This is something we've seen very infrequently, though we're not positive of the cause -- it seems to indicate there is data that is out of sync in the database.

If you get the error, try to restart the upgrade again. You may need to do this a few times, but it will eventually go through (the number will increase each time, eventually moving past the inconsistency).