1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 Unknown column 'custom_fields' in 'field list'

Discussion in 'Installation, Upgrade, and Import Support' started by Renada, Oct 6, 2011.

  1. Renada

    Renada Active Member


    On a test installation I get this error on step 3 of the upgrade.

    Server Error
    Mysqli prepare error: Unknown column 'custom_fields' in 'field list'
        Zend_Db_Statement_Mysqli->_prepare() in /home/sites/xxxxx.com/public_html/test/forum/library/Zend/Db/Statement.php at line 115
        Zend_Db_Statement->__construct() in /home/sites/xxxxx.com/public_html/test/forum/library/Zend/Db/Adapter/Mysqli.php at line 381
        Zend_Db_Adapter_Mysqli->prepare() in /home/sites/xxxxx.com/public_html/test/forum/library/Zend/Db/Adapter/Abstract.php at line 478
        Zend_Db_Adapter_Abstract->query() in /home/sites/xxxxx.com/public_html/test/forum/library/XenForo/Install/Upgrade/1010031-100b1.php at line 516
        XenForo_Install_Upgrade_1010031->step4() in /home/sites/xxxxx.com/public_html/test/forum/library/XenForo/Install/Controller/Upgrade.php at line 115
        XenForo_Install_Controller_Upgrade->actionRun() in /home/sites/xxxxx.com/public_html/test/forum/library/XenForo/FrontController.php at line 310
        XenForo_FrontController->dispatch() in /home/sites/xxxxx.com/public_html/test/forum/library/XenForo/FrontController.php at line 132
        XenForo_FrontController->run() in /home/sites/xxxxx.com/public_html/test/forum/install/index.php at line 17
    Thanks in advance,

  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    That error refers to the xf_user_profile.custom_fields field which is new in 1.1. In the upgrade script that field is added in step1 and populated in step4. Apparently step1 failed to add that field which caused an error in step4.

    Did you notice any prior errors while running the upgrade script? Or did you encounter any other problems during the upgrade?

    When you encounter errors like this it is best to restore a backup and start over with the upgrade.
  3. Renada

    Renada Active Member

    Thanks for your help Jake :)

    I've uploaded, restored the database and rerun the upgrade several times now because it doesn't go any further than step 3 and that leaves me with the error in the admin log and a blank page on the forum. I can't get into the ACP to see if there are any error logs and no other errors appeared on screen for steps 1 and 2.

  4. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    You can also look in the xf_error_log table in the database.
  5. Renada

    Renada Active Member

    Hi Jake,

    I downloaded beta 2 and restarted the whole process and it went through without a hitch :)

    Thanks for all your help.

    Renada :)

Share This Page