1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fixed Unexpected behavior when approving posts within a thread

Discussion in 'Resolved Bug Reports' started by Dean, Feb 28, 2012.

  1. Dean

    Dean Well-Known Member

    On my forum: xf1.03 worked great, after upgrading to 1.1.1 & 1.1.2 behavior seemed to have changed. Currently xf.com is exhibiting the same behavior.

    Works as expected:
    Windows XP IE8
    EDIT: it also works as expected if the post being approved is the first post in the thread in all browsers.

    Does not work as expected (see pictures below):
    Windows XP Chrome 13.0?, Firefox 9.0.1, Safari 5.0.3
    Mac Book Pro OSX 10.7.2 Safari 5.1.1
    Mac Book Pro OSX 10.7.3 Safari 5.1.3

    If a post is moderated, and needs approving:
    Screen Shot 2012-02-28 at 3.33.41 PM.png

    Click on the title to get to the post that needs approving:
    Screen Shot 2012-02-28 at 3.34.06 PM.png

    Select the post, click Approve. Then even though the post has been approved the post is still selected (instead of being unselected).
    Screen Shot 2012-02-28 at 3.34.39 PM.png

    In addition, going to the top of the page, the moderation queue is not updated
    Screen Shot 2012-02-28 at 3.33.41 PM.png



    A page refresh is needed to get things appearing correctly:
    Screen Shot 2012-02-28 at 3.35.17 PM.png

    Screen Shot 2012-02-28 at 3.57.37 PM.png
     
  2. Mike

    Mike XenForo Developer Staff Member

    I'm unable to reproduce this. I can unapprove a message via inline mod (dropdown) and then approve it via the big "approve" button.

    Can you still reproduce this? Can anyone else reproduce it?
     
  3. Mike

    Mike XenForo Developer Staff Member

    With Brogan's help, I reproduced this and have fixed it locally now.
     
    erich37 and Alien like this.
  4. Dean

    Dean Well-Known Member

    Sorry I did not get back to this sooner Mike.
    Thanks Brogan! (y)
     

Share This Page