1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

unable to use mms:// URL

Discussion in 'Troubleshooting and Problems' started by Ryan Kent, May 20, 2011.

  1. Ryan Kent

    Ryan Kent Well-Known Member

    I want to offer the following URL as a hyperlink in a post:


    I tried using
    [url=mms://stream.thisisgame.com/ncsoftext/this//1UPLOAD_HERE/press/BnS_CBT1closing.wmv] watch video [/url] 
    The issue is the http:// tag is added as a prefix which makes it not work. Also, when using the Insert/Edit link button the http:// is also added. If I copy the link and paste it into a browser, it works. How can I offer it as a link?
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    There is no configurable option to change that behavior. You can do it with a code modification:


    Find this code:

    		if (preg_match('#^(https?|ftp)://#i', $url))
    			return $url;
    Change to this:

    		if (preg_match('#^(https?|ftp|mms)://#i', $url))
    			return $url;
    Ideally you will want to make this into an addon rather than modify the files directly.

    Or you can probably do it with HTML:

    bogus and Brogan like this.
  3. Brogan

    Brogan XenForo Moderator Staff Member

    Just for reference, I've flagged this to the dev's in case they want to make the change in the code.
    James likes this.
  4. James

    James Well-Known Member

    They'd be better off making an ACP option of the valid prefixes for URLs (this way people can use http|https|ftp|skype|mms|etc).
  5. bogus

    bogus Guest

    I had same issues with irc urls. Read the last post in here
    Looks like as if the methode from Jake is not working anymore?

Share This Page