Unable to upload via mobile device.

ineedhelp

Well-known member
Is anyone here able to upload images via your mobile phone or tablet ?

Members on my site aren't able to since I've upgraded. Worked fine till 1.1.5. Not sure if the issue happened in the beta or RC upgrades. But in this latest upgrade I'm not able to upload.

When I click Upload a File from my iPhone it lets me browse my photos or lets me take a new one. But once I've selected it. The upload process never ends.

This is happening on other devices as well, Samsung etc.

The same seems to be happening when trying to upload a test image on here in the Test section.

So is everyone effected by this and are the devs aware of this issue?
 

Jeremy

Well-known member
I've uploaded an image just fine from my iPhone. What phone are you testing from and what OS version?
 

ineedhelp

Well-known member
I've uploaded an image just fine from my iPhone. What phone are you testing from and what OS version?
iOS6 the latest update. iPhone 5. Previously using the same phone and software, I had no issues. Nor did other members using different devices.
 

Brogan

XenForo moderator
Staff member
Didn't you just rebuild your server yourself?

Check the server error logs to try and identify what the issue is.

On the face of it though, as you are able to upload, this doesn't sound like a bug to me.
 

Jeremy

Well-known member
The software won't expose directory permission issues except on install just like it doesn't expose errors related to the inner workings except in debug mode.
 

ineedhelp

Well-known member
For example I can upload the attached pic on here just fine from my computer... But when I try attaching the same pic on my forum, from my computer I get the error message I posted above.

Never had this issue before.
 

Attachments

ineedhelp

Well-known member
Also how did the pic I just uploaded reduce in size? How can I add this feature on my site? Or is it already part of 1.2 ?
 

ineedhelp

Well-known member
Could this error hold any clues?

[Wed Aug 14 22:12:53 2013] [error] [client xx.xx.xxx.xxx] Options FollowSymLinks or SymLinksIfOwnerMatch is off which implies that RewriteRule directive is forbidden: /xxxx/xxxx/xxxx/xxxxxx/httpdocs/index.pl, referer: http://barfilounge.com/threads/miss-j-test.17575/page-2
Under 1mb files seem to upload but not the bigger files…… Also in PHP settings 'upload_max' is set to 16M now but still not working.
 

ineedhelp

Well-known member
^That's the error message in server logs.

Didn't you just rebuild your server yourself?

Check the server error logs to try and identify what the issue is.

On the face of it though, as you are able to upload, this doesn't sound like a bug to me.
 
Top