1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Unable to Post

Discussion in 'Troubleshooting and Problems' started by Cambion, Oct 4, 2014.

  1. Cambion

    Cambion Well-Known Member

    So the issue has seemingly worked itself out however I'd like to try and figure out what caused the issue in the first place so i can prevent it from happening.

    I jumped on my forum to check on things and I get a super long group PM from one of my users stating they were unable to post. This was happening to all my users...I got the PM 5 hours later and the problem had worked itself out somehow.

    I get on FB to see a message that more or less told me the Issue had been going on since at least 11 PM est or 9 hours or so without me realizing it. Which bugs me.

    The issues they reported

    1. Anytime they posted it would say "A Server Error Occurred. Please try again."

    2. Zend_Db_Statement_Mysqli->_prepare() in Zend/Db/Statement.php at line 115 Zend_Db_Statement->__construct() in Zend/Db/Adapter/Mysqli.php at line 381 Zend_Db_Adapter_Mysqli->prepare() in Zend/Db/Adapter/Abstract.php at line 478 Zend_Db_Adapter_Abstract->query() in XenForo/Search/SourceHandler/MySqlFt.php at line 110 XenForo_Search_SourceHandler_MySqlFt->_pushToIndex() in XenForo/Search/SourceHandler/MySqlFt.php at line 82 XenForo_Search_SourceHandler_MySqlFt->insertIntoIndex() in XenForo/Search/Indexer.php at line 44 XenForo_Search_Indexer->insertIntoIndex() in

    3. Waindigo/PostAsUser/Extend/XenForo/ControllerPublic/Thread.php at line 82 Waindigo_PostAsUser_Extend_XenForo_ControllerPublic_Thread->actionAddReply() in XenForo/FrontController.php at line 347 XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134

    I am unsure what Waindigo's thing was doing wrong as it has been installed for awhile with no issue nor had i installed anything else.......

    I logged into ACP and it was saying something about the Search index crashed(idk what that is) and needs to be repaired.

    Any help would be welcomed!
  2. Brogan

    Brogan XenForo Moderator Staff Member

    Rebuild the search index in the ACP -> Tools -> Rebuild Caches
  3. Cambion

    Cambion Well-Known Member

    Just finished that, thanks.

    Is that what caused people to be unable to post though?
  4. Brogan

    Brogan XenForo Moderator Staff Member

    Yes, as when posts are created the search index is updated.
  5. Cambion

    Cambion Well-Known Member

    Here i was thinking it was a host/server error thing. I even reached out and contacted them to see what the issue was and why my users were unable to post for the last 9 hours.


    How often should we rebuild search index on our sites? It seemed so odd that the error randomly happened.
  6. Brogan

    Brogan XenForo Moderator Staff Member

    It should never need rebuilding under normal circumstances.

    Crashed tables are indicative of server issues, typically MySQL restarting unexpectedly.
    Cambion likes this.

Share This Page