1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fixed Unable to Edit Big Posts

Discussion in 'Resolved Bug Reports' started by DFI, Aug 5, 2013.

  1. DFI

    DFI Active Member

    I am experiencing some wierd bug after upgrading to Xf 1.2 while editing big posts. Smaller Posts are easily getting edited but whenever i or any other member is trying to edit, it shows blank post.

    [​IMG]


    Checked all User and settings in ACP but it seems uncurable .

    Please help with solution.
     
  2. Amaury

    Amaury Well-Known Member

    Have you tried clearing your browser data?
     
  3. DFI

    DFI Active Member

    Yes, Each and every moderator the same issue at their end.

    Small posts are getting edited but big one become blank as shown above.
     
  4. Mike

    Mike XenForo Developer Staff Member

    Open the edit link in a new tab. Any different?

    Open the developer tools in your browser - any error message?

    Could you link us to a message with the problem?
     
  5. DFI

    DFI Active Member

    1. Tried but no Changes. I still shows blank
    2. Sorry, but don't know how to do that
    3. Here is the message link which is not getting edited and all similar posts with equal length are behaving the same

    Tata Sky Complete Channel List !!
     
  6. Mike

    Mike XenForo Developer Staff Member

    This isn't something that I can reproduce locally - I basically doubled the length of the example post and had no problems editing it in IE, Firefox, or Chrome.

    Can you submit a ticket with FTP and admin CP access so I can attempt to reproduce the issue and debug it?
     
  7. yugiohhh

    yugiohhh Member

    Last edited: Aug 6, 2013
  8. DFI

    DFI Active Member

    I have raised the ticket. Actually its very wierd. When I am creating another thread of similar length, I am too able to create and edit but unable to EDIT these old important lists which got upgraded from XF 1.1.5
     
  9. sonnb

    sonnb Well-Known Member

    Do you have any addon related to posts?
     
  10. DFI

    DFI Active Member

    Nope. The 1st thing I did to find out the reason was disabling each and every add on and then try to edit but issue remained the same.
     
  11. grizone

    grizone Member

    what browser you are use and what version.
    Today I found a similar bug in firefox v. 23 on xenforo 1.1.4
    [​IMG]
     
  12. Mike

    Mike XenForo Developer Staff Member

    I did confirm it on your server, but I need FTP access to debug it. See the ticket you submitted. (Though it's not something I'll be able to look at for a couple days now.)
     
  13. Mike

    Mike XenForo Developer Staff Member

    This looks like it might be dependent on PCRE settings - I think one of the regexes was backtracking too much. It likely only comes up with posts from 1.1 or before that were heavily formatted in the WYSIWYG editor.

    Regardless, changing library/XenForo/BbCode/Formatter/Wysiwyg.php fixes it. Replace:
    Code:
    '#<(xf' . $i . ':([a-z0-9-]+))([^>]*)(?<!/)>(.*)</\\1>#siU',
    with:
    Code:
    '#<(xf' . $i . ':([a-z0-9-]+))([^>]*)(?<!/)>((?:(?>[^<]*?)|<)*)</\\1>#siU',
     
  14. sonnb

    sonnb Well-Known Member

    By default PCRE would limit matched string at 1000.
     

Share This Page