• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.2 Unable to delete file after uninstalling add-on

#1
I installed a Birthday notification add-on (XenFacil Birthday Greetings, big mistake) and after uninstalling it I'm left with files I cannot delete. Normally I wouldn't care but I am receiving over 600 alerts daily on my server as shown below.

The add-on has already been removed along with the cron job.

When I try to delete the files left in the library directory the deletion fails. I've tried changing the permissions but this reverts back to the original permissions upon refresh. I tried this through both cpanel and ftp. One file in particular, Birthdays.php is a cron file that will not allow the permissions to be changed from 644.

I receive approximately 600 of these alerts per day.
Time: Tue Sep 24 01:10:32 2013 -0400
File: /tmp/phpeg7Psi3401083/upload/library/XenFacil/BirthdayGreetings/CronEntry/Birthdays.php
Reason: Script, file extension
Owner: nobody:nobody (99:99)
Action: No action taken
Anyone have an idea on how to end this misery?!
 

Mike

XenForo developer
Staff member
#5
That file is in /tmp, at least according to the error message. There's (almost) no way your forum is actually there...

But regardless, you'd need to be root to delete that file. It's 0644 but it's owned by "nobody" (Apache), so only Apache (or root) can delete that.
 
#6
Right, had to delete this and a dozen more from that same add-on using root. I'll have to be more careful what add-ons I load in the future.