1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 Unable to complete upgrade

Discussion in 'Installation, Upgrade, and Import Support' started by Cory Booth, Mar 27, 2013.

  1. Cory Booth

    Cory Booth Well-Known Member

    After uploading and reuploading all upgrade files (1.1.3 to 1.1.4) I get this "
    An upgrade was found for a version of XenForo that is newer than the uploaded files. Please reupload all of the files for the new version and reload this page."
  2. Brogan

    Brogan XenForo Moderator Staff Member

    Download the 1.1.4 upgrade .zip package again.

    Unzip it and upload it to your server.

    Then perform the upgrade again.
  3. Cory Booth

    Cory Booth Well-Known Member

    Did this twice before posting... I'll do it again...
  4. Cory Booth

    Cory Booth Well-Known Member

    Face Palm... I forgot... I need to clear OPCode Cache from APC.php

    Happens with plugins from time to time. I may need to relook at my APC settings
    Jake Bunce likes this.
  5. erich37

    erich37 Well-Known Member

    what is this ?

    I am just curious, as I want to do my XF-upgrade myself this time....
  6. Cory Booth

    Cory Booth Well-Known Member

    I am running two caching mechanisms... APC and Memcache.
    If you are not (and you would of had to configure this yourself) running APC - no worries
    Dodgeboard and erich37 like this.
  7. Deebs

    Deebs Well-Known Member

    He has disabled stat checking of PHP files in APC, IOW, APC cannot detect when a PHP file has been changed and flush it from the cache. This is a manual process whilst stat checking is disabled.
  8. CyclingTribe

    CyclingTribe Well-Known Member

    Presumably this relates to the "stat" setting for PHP. It decides if APC should check each file that has been cached against the local one on disk to see if it has been recently modified? With stat=1 enabled, if the file has been modified it will recompile the PHP code and cache the new version. With stat=0 it will not check and use the one in cache.

    The benefit of having it on (1) is that any time you make changes to a PHP file you will not have to manually flush the APC cache to see the changes live. The downside is that it creates a slight performance hit as each file must have an additional stat() call to check for the file modified time.

    It's usually advised to turn it off (0) in a production environment - presumably on the basis that you're not going to change things very often, so will benefit from the reduction of stat file modified checks - but for pushing out an XF / add-on upgrade you'll probably want it set to on (1) for ease of use.

    NB: I use Apache so flushing the cache manually is just a case of restarting Apache.

    Shaun :D
  9. CyberAP

    CyberAP Well-Known Member

    @Deebs how did you clear the cache? I am running forum with Apc caching and had the same error from the first post. Tried
    php -r "apc_clear_cache();"
    in console, but it said there is no such function.
  10. CyberAP

    CyberAP Well-Known Member

    My fault. Uploaded Beta 2 instead of RC2 :D

Share This Page