1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Unable To Change Username

Discussion in 'Troubleshooting and Problems' started by Divvens, Nov 4, 2014.

  1. Divvens

    Divvens Well-Known Member

    I have a user who requested a username change, however when I try to change the username and click on "save user" no changes take place, as in I just get the loading animation and it doesn't refresh the page nor save any changes.

    These are the user stats (in case it matters)
    Messages: 4,541
    Likes Received: 25,143

    And the user has given out a lot of likes/has been quoted a lot. I presume those things cause an issue, but I get no error of any sort after trying to save user, it just doesn't save the username.
     
  2. Amaury

    Amaury Well-Known Member

    I doubt that'd be the cause.

    Is it only that user or all users?
     
  3. Divvens

    Divvens Well-Known Member

    I haven't tried changing any other users name since no one requires it currently. I'll try it on a user with the same amount of activity later on today.
     
  4. Xon

    Xon Well-Known Member

    This is a result of username renames being quite intensive, and if your server isn't up-to-spec the request times out and then rolls the partial changes back.

    Ideally in the future it will use the deferrable units of work and incrementally change all the references, but it doesn't do that yet.
     
  5. Divvens

    Divvens Well-Known Member

    I see, that is what is probably happening to me. I guess I'll need to wait until XenForo can support name changes via the deferred method.
     

Share This Page