1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Twitter MediaSite BBcode [Deleted]

Discussion in 'Add-on Releases' started by EQnoble, Jan 23, 2013.

  1. EQnoble

    EQnoble Well-Known Member

    DFI likes this.
  2. dwi

    dwi Member

    I have a problem. I have tweets button disabled, so I uncommented that line in addon-twitterBbcode.xml, but Tweets still looks this weird and non-twittery unlike those on your screenshots. (Flexile style)

    [​IMG]

    And code below, this should be ok, correct?

    [​IMG]
     
  3. Roberto Bilić

    Roberto Bilić Active Member

    I install plugin, but cannot see tweet

    Post on my board with Tweet test
    Tweet on Twitter
    BB Code: [media=twitter]294418057974128640[/media]

    Using CloudFlare (I made a purge cache)
    Using cache in xenForo (Manual remove all xf_*)

    What I do wrong?
     
  4. EQnoble

    EQnoble Well-Known Member

    did you uncomment that line in the flexile style that you are using...or a different style?
     
  5. dwi

    dwi Member

    I uncommented that line in addon-twitterBbcode.xml

    [​IMG]
     
  6. Case

    Case Active Member

    I've got the tweet button disabled so I uncommented that line in the style I'm using. Tweets don't show up at all though. All it seems to put into the post is <div class="tWwrapps"></div>
     
  7. EQnoble

    EQnoble Well-Known Member

    can you link me to your forum
     
  8. dwi

    dwi Member

  9. EQnoble

    EQnoble Well-Known Member

  10. EQnoble

    EQnoble Well-Known Member

    ftp to your site and edit library/MediaSites/listeners/twitter.php
    Find:
    PHP:
    $json file_get_contents('https://api.twitter.com/1/statuses/oembed.json?id=' $mediaKey '&omit_script=true&align=left&maxwidth=400');  // getting the tweet info
    replace the code above with the following:
    PHP:
    $json file_get_contents('https://api.twitter.com/1/statuses/oembed.json?id=' $mediaKey '&omit_script=false&align=left&maxwidth=400');  // getting the tweet info
     
  11. Case

    Case Active Member

    That code is actually in the library/MediaSites/Twitter.php file - correct?

    I've replace it in that file and uploaded it but it doesn't seem to have worked.
     
  12. Case

    Case Active Member

    Would I need to refresh the cache or anything after making this change?
     
  13. EQnoble

    EQnoble Well-Known Member

    yes you are correct...but that should fix it...i played around with it switching it back and forth and didn't have to refresh anything except the page...

    I need a link or I probably can not help you anymore with this.
     
  14. Case

    Case Active Member

    PM'd a link.
     
  15. RobParker

    RobParker Well-Known Member

    I've just installed this with no alterations etc and my tweets look exactly the same as above after making a post. However, if I then hit refresh they have the correct twitter styling. Is this somehow related to the styling not downloading when it's embedded?
     
  16. EQnoble

    EQnoble Well-Known Member

    it is because the of the way the js twitter provides works and the fact that the new post is added a la ajax...this only happens for the person posting it until the next page refresh as you said and it will not happen for anyone viewing it...

    it also will show that way until the twitter js re styles it on pageload...so you may also see that when the page first starts loading
     
  17. RobParker

    RobParker Well-Known Member

    Yep, thought so. I assume there's nothing that can be done about it but its not a major issue anyway.
     
  18. EQnoble

    EQnoble Well-Known Member

    i bet you can make it fire the script again on posting...but to me it is a waste....you have to refresh the page anyways to see if someone responded to you :)
     
  19. DFI

    DFI Active Member

    Works Smoothly. I wish to have similar working for Facebook videos.
     
  20. RobParker

    RobParker Well-Known Member

Share This Page