• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Tweet It [Deleted]

au lait

Well-known member
#1
au lait submitted a new resource:

[by PiX-house.com] Tweet It - Tweet a Thread or post

With this addon can when creating a thread, this automatically be tweeted on Twitter. Or tweeters a post manually.

Step 1 - Go to Twitter Application Management and sign in with your account
Step 2 - Press 'Create a new application' button
Step 3 - Complete the required fields and press 'Create your Twitter application' (in the bottom of the screen)
Step 4 - Go to 'Settings' TAB and set Application Type to 'Read and Write'. Then press...
Read more about this resource...
 
#2
I installed it however if anyone tries reading a thread the get the following error.

An exception occurred: Invalid model 'phc_tweetIt_Model_tweeterMOdel' specified in /home/satguys/public_html/xen/library/XenForo/Model.php on line 192
  1. XenForo_Model::create() in phc/tweetIt/Listener/Listener.php at line 29
  2. phc_tweetIt_Listener_Listener::template_hook()
  3. call_user_func_array() in XenForo/CodeEvent.php at line 58
  4. XenForo_CodeEvent::fire() in XenForo/Template/Abstract.php at line 285
  5. XenForo_Template_Abstract->callTemplateHook() in /home/satguys/public_html/xen/internal_data/templates/S.38,L.1,thread_view.php at line 1319
  6. include() in XenForo/Template/Abstract.php at line 260
  7. XenForo_Template_Abstract->_renderInternal() in XenForo/Template/Abstract.php at line 191
  8. XenForo_Template_Abstract->render() in XenForo/Template/Public.php at line 110
  9. XenForo_Template_Public->render() in XenForo/ViewRenderer/HtmlPublic.php at line 123
  10. XenForo_ViewRenderer_HtmlPublic->renderContainer() in XenForo/FrontController.php at line 618
  11. XenForo_FrontController->renderView() in XenForo/FrontController.php at line 158
  12. XenForo_FrontController->run() in /home/satguys/public_html/xen/index.php at line 13
I am running PHP 5.4.41 - Have the OpenSSL extention loaded and have Curl enabled.

Click There for my ---> phpinfo()
 

RWonko

Active member
#5
I'm getting it after the update,
An exception occurred: Invalid model 'phc_tweetIt_Model_tweeterMOdel' specified in /home/pcsg/public_html/library/XenForo/Model.php on line 192

  1. XenForo_Model::create() in phc/tweetIt/Listener/Listener.php at line 29
  2. phc_tweetIt_Listener_Listener::template_hook()
  3. call_user_func_array() in XenForo/CodeEvent.php at line 58
  4. XenForo_CodeEvent::fire() in XenForo/Template/Abstract.php at line 285
  5. XenForo_Template_Abstract->callTemplateHook() in /home/pcsg/public_html/internal_data/templates/S.8,L.1,thread_view.php at line 1978
  6. include() in XenForo/Template/Abstract.php at line 260
  7. XenForo_Template_Abstract->_renderInternal() in XenForo/Template/Abstract.php at line 191
  8. XenForo_Template_Abstract->render() in XenForo/Template/Public.php at line 110
  9. XenForo_Template_Public->render() in XenForo/ViewRenderer/HtmlPublic.php at line 123
  10. XenForo_ViewRenderer_HtmlPublic->renderContainer() in XenForo/FrontController.php at line 633
  11. XenForo_FrontController->renderView() in XenForo/FrontController.php at line 158
  12. XenForo_FrontController->run() in /home/pcsg/public_html/index.php at line 13
 
#6
It is now working for me. I installed it and tested it.

However in my options I am not seeing what forums (nodes) to enable it for as is shown in your demo photos. My option page has the 4 blocks for the keys and the check box for link to the post. Nothing else.
 

au lait

Well-known member
#7
I'm getting it after the update,
An exception occurred: Invalid model 'phc_tweetIt_Model_tweeterMOdel' specified in /home/pcsg/public_html/library/XenForo/Model.php on line 192

  1. XenForo_Model::create() in phc/tweetIt/Listener/Listener.php at line 29
  2. phc_tweetIt_Listener_Listener::template_hook()
  3. call_user_func_array() in XenForo/CodeEvent.php at line 58
  4. XenForo_CodeEvent::fire() in XenForo/Template/Abstract.php at line 285
  5. XenForo_Template_Abstract->callTemplateHook() in /home/pcsg/public_html/internal_data/templates/S.8,L.1,thread_view.php at line 1978
  6. include() in XenForo/Template/Abstract.php at line 260
  7. XenForo_Template_Abstract->_renderInternal() in XenForo/Template/Abstract.php at line 191
  8. XenForo_Template_Abstract->render() in XenForo/Template/Public.php at line 110
  9. XenForo_Template_Public->render() in XenForo/ViewRenderer/HtmlPublic.php at line 123
  10. XenForo_ViewRenderer_HtmlPublic->renderContainer() in XenForo/FrontController.php at line 633
  11. XenForo_FrontController->renderView() in XenForo/FrontController.php at line 158
  12. XenForo_FrontController->run() in /home/pcsg/public_html/index.php at line 13
See the Update ;)
 

au lait

Well-known member
#9
It is now working for me. I installed it and tested it.

However in my options I am not seeing what forums (nodes) to enable it for as is shown in your demo photos. My option page has the 4 blocks for the keys and the check box for link to the post. Nothing else.
fixef
 

StRonK

Active member
#10
I get this error when I say create threads

Code:
json_decode(): option JSON_BIGINT_AS_STRING not implemented
XenForo_Application::handlePhpError()
json_decode() in phc/tweetIt/codebird.php at line 1959
Codebird->_parseApiReply() in phc/tweetIt/codebird.php at line 1510
Codebird->_callApiCurl() in phc/tweetIt/codebird.php at line 1452
Codebird->_callApi() in phc/tweetIt/codebird.php at line 490
Codebird->__call() in phc/tweetIt/tweeter/tweeter.php at line 46
Codebird->statuses_update() in phc/tweetIt/tweeter/tweeter.php at line 46
phc_tweetIt_tweeter_tweeter::tweetit() in phc/tweetIt/Extend/XenForo/DataWriter/Discussion/Thread.php at line 24
phc_tweetIt_Extend_XenForo_DataWriter_Discussion_Thread->_postSaveAfterTransaction() in WidgetFramework/XenForo/DataWriter/Discussion/Thread.php at line 12
WidgetFramework_XenForo_DataWriter_Discussion_Thread_Base->_postSaveAfterTransaction() in XenForo/DataWriter.php at line 1423
XenForo_DataWriter->save() in XenForo/ControllerPublic/Forum.php at line 748
XenForo_ControllerPublic_Forum->actionAddThread() in XenForo/FrontController.php at line 347
XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
XenForo_FrontController->run() in /home/xenforotr/public_html/index.php at line 13
Server Error Logs
Code:
ErrorException: json_decode(): option JSON_BIGINT_AS_STRING not implemented - library/phc/tweetIt/codebird.php:1959


Code:
#0 [internal function]: XenForo_Application::handlePhpError(2, 'json_decode(): ...', '/home/sitem...', 1959, Array)
#1 /home/sitem/public_html/library/phc/tweetIt/codebird.php(1959): json_decode('{"created_at":"...', false, 512, 2)
#2 /home/sitem/public_html/library/phc/tweetIt/codebird.php(1510): Codebird->_parseApiReply('{"created_at":"...')
#3 /home/sitem/public_html/library/phc/tweetIt/codebird.php(1452): Codebird->_callApiCurl('POST', 'statuses/update', Array, false, false)
#4 /home/sitem/public_html/library/phc/tweetIt/codebird.php(490): Codebird->_callApi('POST', 'statuses/update', Array, false, false)
#5 /home/sitem/public_html/library/phc/tweetIt/tweeter/tweeter.php(46): Codebird->__call('statuses_update', Array)
#6 /home/sitem/public_html/library/phc/tweetIt/tweeter/tweeter.php(46): Codebird->statuses_update('status=test htt...')
#7 /home/sitem/public_html/library/phc/tweetIt/Extend/XenForo/DataWriter/Discussion/Thread.php(24): phc_tweetIt_tweeter_tweeter::tweetit('test', Array, Array, 'thread')
#8 /home/sitem/public_html/library/WidgetFramework/XenForo/DataWriter/Discussion/Thread.php(12): phc_tweetIt_Extend_XenForo_DataWriter_Discussion_Thread->_postSaveAfterTransaction()
#9 /home/sitem/public_html/library/XenForo/DataWriter.php(1423): WidgetFramework_XenForo_DataWriter_Discussion_Thread_Base->_postSaveAfterTransaction()
#10 /home/sitem/public_html/library/XenForo/ControllerPublic/Forum.php(748): XenForo_DataWriter->save()
#11 /home/sitem/public_html/library/XenForo/FrontController.php(347): XenForo_ControllerPublic_Forum->actionAddThread()
#12 /home/sitem/public_html/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
#13 /home/sitem/public_html/index.php(13): XenForo_FrontController->run()
#14 {main}
 

BobbyWibowo

Well-known member
#16
Can you add an option to tweet only the title instead of the content? But of course retain the ability to include link as well.
Also, if the content has BBCode in it, the BBCode will be tweeted as well. Can you prevent that somehow?
Thanks in advance.

EDIT: Also, changes to tweetit_post_private_controls template isn't being reflected to the site.
 
Last edited:

au lait

Well-known member
#18
Can you add an option to tweet only the title instead of the content? But of course retain the ability to include link as well.
Also, if the content has BBCode in it, the BBCode will be tweeted as well. Can you prevent that somehow?
Thanks in advance.

EDIT: Also, changes to tweetit_post_private_controls template isn't being reflected to the site.
New version in which the bbCodes be removed. And an option to selected text or Message to twitter