Trust+ [Deleted]

Shiro

Well-known member
ok, i am not sure if it`s working now. Just reinstalled. I installed TOR, and tried to register in my Forum: Sorry, we cannot create an account for you at this time. Please contact the staff if this error persists.

Where can i find the Logs from Trust+? And can i translate this Error Message to German? A completely German Translation would be nice.

Thx m8

//

Code:
Aktion: Abgelehnt - Trust+ blocked a registration attempt: score 11701, tag ip/net/server (1200), tag ip/open-port/443 (1), tag ip/open-port/80 (500), tag ip/tor-exit (10000), IP 5.79.68.161, user agent "Mozilla/5.0 (Windows NT 6.1; rv:38.0) Gecko/20100101 Firefox/38.0"
A German translation would be wonderful. You're welcome to translate. That log indicates it is working.
 

The Sandman

Well-known member
Detect and optionally block users who may be behind HTTP or SOCKS proxies by use of an open proxy scan. (scoring customization required)
What scoring customization is required for this?

Thanks!
 

The Sandman

Well-known member
I've gotten at least 10 of these errors since installing this yesterday:
Code:
Error Info
TrustPlus\ConnectionFailureException: Failed to query the Trust+ API. The following exception occurred: - library/TrustPlus/Client.php:105
Generated By: Unknown Account, Yesterday at 10:30 AM
Stack Trace
#0 /srv/www/theadminzone.com/public_html/library/TrustPlus/Client.php(246): TrustPlus\_RPCClient->execute('trustplus.Check', Array)
#1 /srv/www/theadminzone.com/public_html/library/TrustPlus/ControllerPublic/Register.php(45): TrustPlus\Client->check(Array)
#2 /srv/www/theadminzone.com/public_html/library/XenForo/ControllerPublic/Register.php(401): TrustPlus_ControllerPublic_Register->_runSpamCheck(Object(DigitalPointSearch_DataWriter_User), Array)
#3 /srv/www/theadminzone.com/public_html/library/UserEss/ControllerPublic/Register.php(68): XenForo_ControllerPublic_Register->actionRegister()
#4 /srv/www/theadminzone.com/public_html/library/XenForo/FrontController.php(351): UserEss_ControllerPublic_Register->actionRegister()
#5 /srv/www/theadminzone.com/public_html/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
#6 /srv/www/theadminzone.com/public_html/index.php(13): XenForo_FrontController->run()
#7 {main}
Request State
array(3) {
  ["url"] => string(42) "https://theadminzone.com/register/register"
  ["_GET"] => array(1) {
    ["/register/register"] => string(0) ""
  }
  ["_POST"] => array(16) {
    ["username"] => string(0) ""
    ["e5b08f5c2c043aa748190ea88405c2fe"] => string(8) "nvc98810"
    ["d304bed46aa5545f6f9675f064ce43e4"] => string(18) "nvc98810@foxja.com"
    ["205a57de7151ef742160d1eb8e67624d"] => string(4) "male"
    ["cav_token"] => string(36) "04f5b695-8f9b-11e5-a9f2-fa163e2db18f"
    ["dob_month"] => string(1) "6"
    ["dob_day"] => string(2) "22"
    ["dob_year"] => string(4) "1980"
    ["b544e5a17acf997ca15fdee30281d493"] => array(4) {
      ["aw50zxjlc3rlza"] => string(0) ""
      ["interested"] => string(4) "bord"
      ["whatdoyouwant"] => string(0) ""
      ["real_name"] => string(3) "lee"
    }
    ["custom_fields_shown"] => array(5) {
      [0] => string(14) "aw50zxjlc3rlza"
      [1] => string(10) "interested"
      [2] => string(13) "whatdoyouwant"
      [3] => string(9) "real_name"
      [4] => string(14) "board_software"
    }
    ["64330b64dd830b4bde5cb6b68bd579c6"] => string(10) "Asia/Tokyo"
    ["captcha_question_answer"] => string(2) "12"
    ["captcha_question_hash"] => string(40) "f08aa54fbbb8aef1879f719fdb03bf5576f0676a"
    ["agree"] => string(1) "1"
    ["_xfToken"] => string(8) "********"
    ["reg_key"] => string(32) "a769cd4f54878e7c0cb8e098f9f8387b"
  }
}
 

Shiro

Well-known member
I've gotten at least 10 of these errors since installing this yesterday:
Code:
Error Info
TrustPlus\ConnectionFailureException: Failed to query the Trust+ API. The following exception occurred: - library/TrustPlus/Client.php:105
Generated By: Unknown Account, Yesterday at 10:30 AM
Stack Trace
#0 /srv/www/theadminzone.com/public_html/library/TrustPlus/Client.php(246): TrustPlus\_RPCClient->execute('trustplus.Check', Array)
#1 /srv/www/theadminzone.com/public_html/library/TrustPlus/ControllerPublic/Register.php(45): TrustPlus\Client->check(Array)
#2 /srv/www/theadminzone.com/public_html/library/XenForo/ControllerPublic/Register.php(401): TrustPlus_ControllerPublic_Register->_runSpamCheck(Object(DigitalPointSearch_DataWriter_User), Array)
#3 /srv/www/theadminzone.com/public_html/library/UserEss/ControllerPublic/Register.php(68): XenForo_ControllerPublic_Register->actionRegister()
#4 /srv/www/theadminzone.com/public_html/library/XenForo/FrontController.php(351): UserEss_ControllerPublic_Register->actionRegister()
#5 /srv/www/theadminzone.com/public_html/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
#6 /srv/www/theadminzone.com/public_html/index.php(13): XenForo_FrontController->run()
#7 {main}
Request State
array(3) {
  ["url"] => string(42) "https://theadminzone.com/register/register"
  ["_GET"] => array(1) {
    ["/register/register"] => string(0) ""
  }
  ["_POST"] => array(16) {
    ["username"] => string(0) ""
    ["e5b08f5c2c043aa748190ea88405c2fe"] => string(8) "nvc98810"
    ["d304bed46aa5545f6f9675f064ce43e4"] => string(18) "nvc98810@foxja.com"
    ["205a57de7151ef742160d1eb8e67624d"] => string(4) "male"
    ["cav_token"] => string(36) "04f5b695-8f9b-11e5-a9f2-fa163e2db18f"
    ["dob_month"] => string(1) "6"
    ["dob_day"] => string(2) "22"
    ["dob_year"] => string(4) "1980"
    ["b544e5a17acf997ca15fdee30281d493"] => array(4) {
      ["aw50zxjlc3rlza"] => string(0) ""
      ["interested"] => string(4) "bord"
      ["whatdoyouwant"] => string(0) ""
      ["real_name"] => string(3) "lee"
    }
    ["custom_fields_shown"] => array(5) {
      [0] => string(14) "aw50zxjlc3rlza"
      [1] => string(10) "interested"
      [2] => string(13) "whatdoyouwant"
      [3] => string(9) "real_name"
      [4] => string(14) "board_software"
    }
    ["64330b64dd830b4bde5cb6b68bd579c6"] => string(10) "Asia/Tokyo"
    ["captcha_question_answer"] => string(2) "12"
    ["captcha_question_hash"] => string(40) "f08aa54fbbb8aef1879f719fdb03bf5576f0676a"
    ["agree"] => string(1) "1"
    ["_xfToken"] => string(8) "********"
    ["reg_key"] => string(32) "a769cd4f54878e7c0cb8e098f9f8387b"
  }
}
Do you have a test installation that we can access to assist in debugging purposes? My associate is looking into this now as well.
 

adwade

Well-known member
This error message was displayed at the top of my Registration Page, when trying to register as a new test user…
Screen Shot 2015-12-06 at 9.30.57 PM.jpg

I got this message when trying to create a new test account on my board, which I'm just getting setup after importing our data over from vB.(i.e. "Sorry, we cannot create an account for you at this time. Please contact the staff if this error persists.")

At first I thought it was a new add-on I had installed, but I ruled that out. Then I thought it was a permissions error perhaps and that I had CHMOD'd some directory incorrectly, somewhere.(i.e. Thinking it could not write the new-user data perhaps.) It's taken me several hours to finally give-up and copy/paste the exact error message into the search function here on XenForo and Thankfully @bambino had quoted this error message in an earlier post. So I turned this add-on OFF and the error has now gone away.

1)Consider a less-cryptic error message, that at least gives (new) admins a clue as to what it is referring to?
UPDATE: You can edit the phrase trustplus_registration_denied for a different error message. (y)
2)Is there a possibility in adding an option to allow registrations to continue normally if/when your service is down?
I learned it already does that.

This is a powerful add-on and I quite like it, but not knowing how often the service is down somewhat worries me…since apparently it will block any registrations during that time.(See Below…)
 
Last edited:

Shiro

Well-known member
This error message was displayed at the top of my Registration Page, when trying to register as a new test user…
View attachment 123450

I got this message when trying to create a new test account on my board, which I'm just getting setup after importing our data over from vB.(i.e. "Sorry, we cannot create an account for you at this time. Please contact the staff if this error persists.")

At first I thought it was a new add-on I had installed, but I ruled that out. Then I thought it was a permissions error perhaps and that I had CHMOD'd some directory incorrectly, somewhere.(i.e. Thinking it could not write the new-user data perhaps.) It's taken me several hours to finally give-up and copy/paste the exact error message into the search function here on XenForo and Thankfully @bambino had quoted this error message in an earlier post. So I turned this add-on OFF and the error has now gone away.

1)Consider a less-cryptic error message, that at least gives (new) admins a clue as to what it is referring to?
2)Is there a possibility in adding an option to allow registrations to continue normally if/when your service is down?

This is a powerful add-on and I quite like it, but not knowing how often the service is down somewhat worries me…since apparently it will block any registrations during that time.
The service is not down. That error message indicates that the registration attempt was rejected, based on your scoring settings. This is a fail open system, if the service is down, registrations will be accepted. Please check your spam log to see what caused the registration rejection.

The error message is cryptic as to not tip-off potential spammers into trying to defeat Trust+. If the Trust+ service is down, registrations WILL be processed as normal.
 

adwade

Well-known member
I just wanted to say Thanxx @Shiro for being so helpful and thorough, in helping me to sort through the issues I encountered.
 
Last edited:

Brent W

Well-known member
I can't thank @Shiro enough for working with us on getting this setup on our largest sites and fixing the issues that we have run into. Everything seems to be running smoothly now and we are catching a lot of spam that would have gotten through otherwise. Highly recommend this to anyone running an XF board.
 
Top