1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Transplanting??

Discussion in 'Installation, Upgrade, and Import Support' started by Bill.D, May 21, 2012.

  1. Bill.D

    Bill.D Active Member

    Ok.. 1st I am a Xenforo noob! :(
    So here is the question: Is it possible to "transplant" a whole Xenforo sites files over to a new server and run it? If so, How? lol

    So I have the DB up & The new server can connect to it.. I have the new server and all the files moved over. The index page comes up fine but when i goto the Forums page i get a blank page with this massage: "The board is currently being upgraded. Please check back later."

    Sorry for the stupid question, Thanks,
    -Bill
     
  2. principia

    principia Well-Known Member

  3. Chris D

    Chris D XenForo Developer Staff Member

    It is possible to move a XenForo site to a different server, yes.

    Has the domain name changed?

    Can you log in to your Admin CP? If the domain name has changed you will need to update the Board URL.

    If you let us know what the site is we might be able to have a look.
     
  4. Bill.D

    Bill.D Active Member

    It has changed.. but i cannot access the Admin CP.. At least I dont think i can.. I going to take a look at the thread posted above and I'll get back if t worked or not. Thanks :LOL:
     
  5. Chris D

    Chris D XenForo Developer Staff Member

  6. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

  7. Bill.D

    Bill.D Active Member

    Ok, So I am not able to get to the Admin.PHP page.. Or rather.. I can but its completely blank o_O.. I did a backup of the DB and placed in a new MySQL server b4 all of this and the Config.PHP is set for the new server and I can confirm that the new host server can access the new MySQL server and select data by command line.. However because i cannot get to the admincp i cannot change the Board URL.. Is there a file somewhere that holds that that i can change manually?
     
  8. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    A blank page is often a suppressed error. Try adding this line to your library/config.php file to see if that reveals any specific error message on the blank page:

    Code:
    ini_set('display_errors', true);
    
     
    Yorick likes this.
  9. Bill.D

    Bill.D Active Member

    So i tryied adding the code above and still nothing o_O.. the page remains blank.. This is my Config.php sans personal info:
    PHP:
    <?php
     
    $config
    ['db']['host'] = 'xx.xxx.xx.xx';
    $config['db']['port'] = '3306';
    $config['db']['username'] = 'xxxxxx';
    $config['db']['password'] = 'xxxxx';
    $config['db']['dbname'] = 'xxxxxx';
     
     
    $config['superAdmins'] = '1';
     
    $config['debug'] = true;
     
    ini_set('display_errors'true);
    I have tried commenting out one & both of the debug & superadmin entries as well as setting debug on and off.
    I have also review anything I could about Apache's setup. I had just a standard setup and also used a copy of the settings from the org server and neither gets me any closer.

    ..a follow up.. I wondered if that last entry needed a '$' infront. I tested it and and makes it so the site is completely unreachable.. So i dont think thats it.. lol
     
  10. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Try disabling addons too:

    Code:
    $config['enableListeners'] = 0;
    
    Otherwise if the problem persists then send me your server and forum login info. I will take a look.
     
  11. Bill.D

    Bill.D Active Member

    :confused:.. didnt work.. but! a clue! I ran the requirements php and it says
    I do have the latest MySQL and it is running tested via "service MySQL status" but they system doesn't seem to see it.. Also that DB that is set in the config is a remote DB and that DB is Also up to date and I test the connection from command line using the setting a placed in the config.php file and that was successful.. Any thoughts?
     
  12. Andrej

    Andrej Well-Known Member

    The requirements.php does not test the MySQL version, so as quoted above you must verify it manually. If everything is OK, you don't need to worry.
     
  13. Bill.D

    Bill.D Active Member

    ok.. then thats not it.. lol.. any other thoughts?
     
  14. Chris D

    Chris D XenForo Developer Staff Member

    It might not work (i.e. blank page again) but try going to http://yourforum.com/install.

    Log in. It will tell you there is no upgrade available but clicking on "Rebuild Master Data" may help. It won't delete anything. But might repair the problem.
     
  15. Bill.D

    Bill.D Active Member

    So still minor progress.. I am able to goto the install site and it asks for a User Name & Pass.. I have entered many different admin users PLUS the Main Admin info and the page goes nowhere.. It just its there after submission.. So I have tried a new installation and replaced the new install's DB with the Old DB.. I get a little further now.. I am able to get Admin.PHP to come up but is simply states:
    So I click the "Complete the Upgrade" option witch just takes me the the install site which acts in the same ways as the attempts above.. I enter the information and nothing happens :-\
     
  16. Bill.D

    Bill.D Active Member

    update.. I have directly accessed the DB and altered Blob that contained the old URL and altered the blod to contain the new URL. System still not working. :-\
     
  17. Strong

    Strong Member

    Did you try clearing your browser cache? I'm not an expert at anything, but I've ran into this problem where simply using a different browser solved it. Another suggestion you might want to consider is to also clear any dns cache your computer has.
     
  18. Bill.D

    Bill.D Active Member

    Hey All.. Update.. Up till this point it was my fault.. Main problem was my uploading method of the Database.. I re-uploaded the DB and then ran an upgrade and now everything shows up.. ALMOST :confused:.. So the site shows and I can see all of the Forum Threads listed.. BUT.. when I click on one all I get is a page "Not Found" and that it cant find it on the server.. Any thoughts ? Thank you for all of the help.. this has been a good crash course :)
     
  19. pjfry

    pjfry Active Member

    Hmm I had a similar issue when switching from one server to another one. My problem was the .htaccess file. So my new server hadn't mod_rewrite enabled and I had to enable this. Another point was this line in my .htaccess:

    Code:
    RewriteBase /
    I had to remove the "#" before this line.

    You could check if it is a rewrite problem by disable here /admin.php?options/list/seo the friendly urls!

    Benny
     
    Strong and Bill.D like this.
  20. Bill.D

    Bill.D Active Member

    W00t!!! Genius!!! Thanks :LOL::LOL::LOL:
     
    pjfry likes this.

Share This Page