1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Not a Bug Translated phrases not always being sent in email

Discussion in 'Resolved Bug Reports' started by AndyB, Nov 15, 2014.

  1. AndyB

    AndyB Well-Known Member

    The following add-on called Weekly Digest:


    has a problem with not always using the translated phrases. In this situation the foreign language phrase will randomly work.

    The Weekly Digest's sends emails via XenForo Cron to members who have been active on the forum for the past 30 days, so typically on average about 100 to 1000 emails are sent once a week.

    What I don't understand is why sometimes the translated phrases are being sent and sometime the English default phrase is being sent.

    Correct email would look like this:


    The incorect email looks like this:

    Last edited: Nov 15, 2014
  2. AndyB

    AndyB Well-Known Member

    Here's an example of one of the phrases which are not always being used in the emails being sent:

  3. Mike

    Mike XenForo Developer Staff Member

    That just looks like it's sending the English (or master) language version. It's not really some phrases -- it's the whole thing.

    As a developer, you control the language that is used to send the mail. It defaults to the language in use by the current page. If you're sending mails to a particular user, you should be setting the mail object to their language.

Share This Page