1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

ToolTip text truncates after space

Discussion in 'XenForo Development Discussions' started by tekboi, Sep 22, 2014.

  1. tekboi

    tekboi Active Member

    Not sure if this is the appropriate section, so sorry in advance.

    I made some template edits to display icons in the postbit when a value is entered. And when the user hovers over the icons, it displays the value. But if there is a space in the value, the tooltip only displays the letters before the space. How can I fix it?

    Here's the code I used.

    Code:
    <xen:if is="{$user.customFields.youtube_id}">
    <a href="http://www.youtube.com/{$user.customFields.youtube_id}" title={$user.customFields.youtube_id} class="Tooltip"/><img src="http://www.vicegamers.com/images/youtubepb.png"/></a>
    </xen:if>
    
    <xen:if is="{$user.customFields.twitch_id}">
    <a href="http://www.twitch.tv/{$user.customFields.twitch_id}" title={$user.customFields.twitch_id} class="Tooltip"/><img src="http://www.vicegamers.com/images/twitch.png"/></a>
    </xen:if>
    
     
    Last edited: Sep 22, 2014
  2. Chris D

    Chris D XenForo Developer Staff Member

    You're missing the "quotes" around the title attribute, e.g.

    Code:
    title={$user.customFields.youtube_id}
    Should be:
    Code:
    title="{$user.customFields.youtube_id}"
     
    tekboi likes this.
  3. tekboi

    tekboi Active Member

    Ahhhh...... thank you sir.
     

Share This Page