• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Not planned titleBar inconsitent when Forum tab is selected

AndyB

Well-known member
#1
I think it would make sense if the titleBar would indicate "Forums" when the Forum tab is selected, currently it shows "XenForo Community".

pic001.jpg

Please click Like if you would like to see this changed.
 

AndyB

Well-known member
#3
It's not consistent in this case because XenForo Community is the name of the forums.
In most cases the logo already states the name of the forum, so it's redundant indicate the forum name again.

To be consistent I think it should say "Forums" as that's the way the other tabs work.
 

Amaury

Well-known member
#4
In most cases the logo already states the name of the forum, so it's redundant indicate the forum name again.

To be consistent I think it should say "Forums" as that's the way the other tabs work.
Correct. Most cases, but not always.

Take a look here, for example. Let's Do the Timewarp is the only style of the three available that has the logo with the site's name in it.
 

AndyB

Well-known member
#5
Good point, Amaury. I suppose that's why it has the forum title instead of the word "Forums" for those that leave the default logo.

On my forum the logo clearly has the forum name, so I tried editing the template to replace my forum name to say Forums, but it looks like it will require a hack to the php code to make the change.
 

Amaury

Well-known member
#6
Good point, Amaury. I suppose that's why it has the forum title instead of the word "Forums" for those that leave the default logo.

On my forum the logo clearly has the forum name, so I tried editing the template to replace my forum name to say Forums, but it looks like it will require a hack to the php code to make the change.
Alternatively, you could just comment out the forum name.

Over on KH-Flare, that's what I did eventually. This is no longer visible:

KH-Flare Forum
Welcome to the KH-Flare Forum
 

AndyB

Well-known member
#8
Hi Jeremy,

Thank you for the suggestion. Before I created this thread that is what I tried. I thought I had it, but it turns out that all forum titles and thread titles said "Forums". That's when I decided to create this thread.

Here's the code snippet from the PAGE_CONTAINER template that I tried to modify. I changed "{xen:raw $beforeH1}" to "Forums".

PHP:
<xen:hook name="page_container_content_title_bar">
<xen:if is="!{$noH1}">            
  <!-- h1 title, description -->
  <div class="titleBar">
  {xen:raw $beforeH1}
  <h1><xen:if
  is="{$h1}">{xen:raw $h1}<xen:elseif
  is="{$title}" />{xen:raw $title}<xen:else
  />{$xenOptions.boardTitle}</xen:if></h1>
  
  <xen:if is="{$pageDescription.content}"><p id="pageDescription" class="muted {$pageDescription.class}">{xen:raw $pageDescription.content}</p></xen:if>
  </div>
</xen:if>
</xen:hook>
 

AndyB

Well-known member
#11
Anyone reading this thread, here's what I did.

1) Edit the forum_list template
2) Change the first line of the template like this:

Original line
<xen:h1>{$xenOptions.boardTitle}</xen:h1>

edited line
<xen:h1>Forums</xen:h1>
 
Last edited: