Not a bug Title changes aren't logged consistently

Affected version
1.5.15

Zenexer

Active member
#1
If a moderator edits a title by clicking Edit -> More Options... and then editing the title in the thread form, it doesn't appear in the Moderator Log, and clicking Thread Options -> Moderator Actions in the thread doesn't show the change. However, if a moderator edits the title by clicking Thread Options -> Edit Thread, it does show in Moderator Actions. This is inconsistent and confusing; if searching for a title change by a moderator, two places have to be searched.
 

Chris D

XenForo developer
Staff member
#4
If a moderator edits a title by clicking Edit -> More Options... and then editing the title in the thread form, it doesn't appear in the Moderator Log, and clicking Thread Options -> Moderator Actions in the thread doesn't show the change.
XF1 doesn't have such a mechanism that allows you to change the title.

The only place you can change the thread title is Thread Tools > Edit Thread or Thread Tools > Edit Thread Title (depending on the manageAnyThread permission). Your post suggests you're editing the thread by editing the first post of a thread?
 

Zenexer

Active member
#5
@Chris D Yes, the scenario that doesn't work as expected is when I edit the thread by editing the first post of a thread. I don't believe that this is the result of an add-on. When editing the first post of a thread, then clicking "More Options..." to get to the full editor, there is a textbox where the thread title can be edited. This is XenForo 1.5.x.
 
Top