• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.4 Threads with 1000 or more pages and page numbering

markku

Well-known member
#1
Screen Shot 2014-12-01 at 18.21.52.png

Screen Shot 2014-12-01 at 18.22.21.png


So as you can see, the space automatically adjusts for 1000 on the forum list, but in the actual thread it doesn't (1000 doesn't fit).

How to fix?
 

markku

Well-known member
#3
https://xenforo.com/community/pages/pagenav-playground/

Does it not work correctly for you here?

I would note that by default, all page navs are identical. The sizes in your screenshot appear to be different, but I don't know if that's a screenshot quirk.
Sorry. It was my fault.

The thing was that a thread on my forum had just gotten to 100 pages, and it looked like this on the forum list:

Screen Shot 2014-12-01 at 18.40.48.png

And then it looked like this on the thread view:

Screen Shot 2014-12-01 at 18.41.05.png


Since the thread view page number 100 was more squished looking than the forum list view (you see how the padding seems to be maintained on the forum list page number 100, unlike in the thread view, where the 100 has less padding than 99), I thought that the the space of the boxes for page numbers doesn't automatically get adjusted in the thread view.

So in my original post, I tried changing the page number from 100 to 1000 in the thread view by using Firebug.

And as you can see from the original post, the size of the box for the page number didn't increase.

However, I also changed the page numbers with Firebug in the forum list view, and those automatically adjusted. You can see in the original post how the forum list page number 1000 box has increased in size properly.


But now having checked out the PageNav Playground, it seems everything looks OK, and if the thread actually (i.e. no Firebug manipulation) gets to 1000 pages, the size of the page number box will automatically adjust in the thread view as well.


What threw me off was that in the forum list view the size of the page number box adjusted accordingly even when manipulating the number with Firebug.

But it didn't adjust the same way when manipulating the number in the thread view.


And I just tested manipulating the number on PageNav Playground, and the same thing happens here:

Screen Shot 2014-12-01 at 18.47.25.png



Which means that I have nothing to worry about. I was just confused by how Firebug affected things.

Thanks :)
 

markku

Well-known member
#4
Also, the screenshots look twice the size due to being taken on a MBP Retina... One of the cons of the retina display.